Bug 128954 - Panic with tracepath6
Summary: Panic with tracepath6
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-02 01:38 UTC by Ralph Loader
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-04 21:37:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralph Loader 2004-08-02 01:38:56 UTC
Description of problem:

Playing around with ping6 / tracepath6 got a panic.

Last few shell commands were:
$ ping6 ::ffff:172.16.21.161
$ tracepath6 ::ffff:172.16.21.161
$ tracepath6 ::172.16.21.161

Version-Release number of selected component (if applicable):

kernel-2.6.6-1.435.2.3 (i686)

How reproducible:

Seems to be tracepath6 ::172.16.21.161 does this every time.

Additional info:

Hand transcribed panic screen:

Eip 04bbb62e
Ooops 0000

Modules: ipt_REJECT ipt_state ip_conntrack iptable_filter iptables
ipv6 e100 mii floppy sg scsi_mod dm_mod ext3 jbd

CPU: 0
EIP 0060:[<04bbb62e>] Not tainted
EFLAGS: 00010202 (2.6.6-1.435.2.3)
EIP is at ipv6_chkaddr+0xf/0x9b [ipv6]

eax: 00000008 ebx: 00000005 ecx: 00000001 edx: 03300800
esi: 02d554c0 edi: 02354fd0 ebp: 00000008 esp: 02345f6c
ds:007b es:007b ss:0068

Process swapper (0, threadinfo: 02345000 task:022c8a80)

Stack: 00000001 03300880 00000005 02d554c0 02345fd0 0360071c 04bc4ace
80000000
       00000246 02049680 03300800 00000000 03600800 0255f012 036006fc
00000246
       00000246 036006a0 429a8990 02345fd0 02345fd0 0223c178 0223c081
036006fc

Call Trace:

[<04bc4ace>] ndisc_solicit+0x42/0x170 [ipv6]
[<0223c178>] neigh_timer_handler+0xf7/0x112
[<0223c081>] neigh_timer_handler+0x0/0x112
[<0211dcab>] run_timer_softirq+0x10b/0x12a
[<02238df8>] net_rx_action+0x5d/0xcd
[<0211ae01>] __do_softirq+0x35/0x73
[<02107390>] do_softirq+0x46/0x4d
[<0210403b>] do_IRQ+0x15d/0x169
[<02112590>] default_idle+0x23/0x26
[<02112590>] apm_cpu_idle+0xe4/0x121
[<0210408c>] cpu_idle+0x1f/0x34
[<0231c518>] start_kernel+0x178/0x17a

Code: 0f b6 40 02 33 45 0c 89 c2 c1 ea 10 31 d0 89 c2 c1 ea 08 31

<0>Kernel Panic: Fatal exception in interrupt
In interrupt handler - not syncing

Comment 1 Ralph Loader 2004-08-04 21:37:01 UTC
Seems to be fixed in kernel-2.6.7-1.494.2.2


Note You need to log in before you can comment on or make changes to this bug.