Bug 1289602 - After detach-tier start writes still go to hot tier
After detach-tier start writes still go to hot tier
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Regression, Reopened, ZStream
Depends On: 1287532
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-12-08 09:28 EST by Mohammed Rafi KC
Modified: 2016-06-16 09:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1287532
Environment:
Last Closed: 2016-06-16 09:49:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-08 09:29:27 EST
REVIEW: http://review.gluster.org/12914 (tier/dht: files are still going to decommissioned subvol) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-12-08 16:50:18 EST
REVIEW: http://review.gluster.org/12914 (tier/dht: files are still going to decommissioned subvol) posted (#2) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 3 Vijay Bellur 2015-12-08 16:50:30 EST
REVIEW: http://review.gluster.org/12914 (tier/dht: files are still going to decommissioned subvol) posted (#3) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 4 Vijay Bellur 2015-12-09 00:44:19 EST
REVIEW: http://review.gluster.org/12914 (tier/dht: files are still going to decommissioned subvol) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 5 Vijay Bellur 2015-12-09 00:44:24 EST
REVIEW: http://review.gluster.org/12914 (tier/dht: files are still going to decommissioned subvol) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 6 Vijay Bellur 2015-12-09 08:35:39 EST
COMMIT: http://review.gluster.org/12914 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit cb41de7c4a7d620dbab645f2b105286b68bde9a9
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Dec 8 19:55:22 2015 +0530

    tier/dht: files are still going to decommissioned subvol
    
    After detach tier start, creates are still going to hot
    tier. Because when creating data files we are not checking for
    decommissioned bricks.
    
    Change-Id: I8e28258d9b2367dcc8ad6e5e91d0e54d92fdf771
    BUG: 1289602
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12914
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 7 Vijay Bellur 2015-12-10 04:09:05 EST
REVIEW: http://review.gluster.org/12937 (tier/dht: files are still going to decommissioned subvol) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 8 Vijay Bellur 2015-12-11 07:26:58 EST
COMMIT: http://review.gluster.org/12937 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 9f35fcf087d5c30d460999d667b1b82dfd08d762
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Dec 8 19:55:22 2015 +0530

    tier/dht: files are still going to decommissioned subvol
    
    After detach tier start, creates are still going to hot
    tier. Because when creating data files we are not checking for
    decommissioned bricks.
    Backpor of>
    >Change-Id: I8e28258d9b2367dcc8ad6e5e91d0e54d92fdf771
    >BUG: 1289602
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/12914
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    (cherry picked from commit cb41de7c4a7d620dbab645f2b105286b68bde9a9)
    
    Change-Id: I56e4551657a234ac51fa2513dc46a48c19c4fac7
    BUG: 1289602
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12937
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 9 Kaushal 2016-04-19 03:50:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 10 Niels de Vos 2016-06-16 09:49:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.