Bug 1289606 - openstack-rally-0.1.1-4.2.el7ost is broken
openstack-rally-0.1.1-4.2.el7ost is broken
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-rally (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: RHOS Maint
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 09:33 EST by Anshul Behl
Modified: 2017-05-29 03:05 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 16:17:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anshul Behl 2015-12-08 09:33:09 EST
Description of problem:

openstack-rally-0.1.1-4.1.el7ost is working fine and because you have removed the post install script, openstack-rally-0.1.1-4.2.el7ost is not able to make the sqllite connection which in turn is breaking the entire rally rpm.


Version-Release number of selected component (if applicable):
openstack-rally-0.1.1-4.2.el7ost

How reproducible:
Everytime

Steps to Reproduce:
#rally deployment list



Actual results:
(sqlite3.OperationalError) no such table: deployments [SQL: u'SELECT deployments.enum_deployments_status AS deployments_enum_deployments_status, deployments.created_at AS deployments_created_at, deployments.updated_at AS deployments_updated_at, deployments.id AS deployments_id, deployments.uuid AS deployments_uuid, deployments.parent_uuid AS deployments_parent_uuid, deployments.name AS deployments_name, deployments.started_at AS deployments_started_at, deployments.completed_at AS deployments_completed_at, deployments.config AS deployments_config, deployments.admin AS deployments_admin, deployments.users AS deployments_users \nFROM deployments \nWHERE deployments.parent_uuid IS NULL']
Looks like Rally can't connect to it's DB.
Make a sure that connection string in rally.conf is proper:
sqlite:////tmp/rally.sqlite

Expected results:

There are no deployments. To create a new deployment, use:
rally deployment create

Additional info:
Comment 2 Jon Schlueter 2015-12-08 13:32:47 EST
No config file is installed and the sample config file does not have a connection string either.

current version of package is openstack-rally-0.1.1-4.2.el7ost

to customize the config for an sqlite DB

copy /etc/rally/rally.conf.sample to /etc/rally/rally.conf
modify the config file to include 

see bug 1155128 for details on how to manually configure and generate the DB
Comment 3 Jon Schlueter 2015-12-08 13:45:50 EST
on my test VM:

I added connection entry to /etc/rally/rally.conf from /etc/rally/rally.conf.sample

cp /etc/rally/rally.conf.sample /etc/rally/rally.conf

add the following to /etc/rally/rally.conf

connection = sqlite:////var/lib/rally/rally.sqlite


then make the directory
mkdir -p /var/lib/rally/

rally-manage db recreate


# rally deployment list
There are no deployments. To create a new deployment, use:
rally deployment create
Comment 4 Jon Schlueter 2015-12-08 16:17:24 EST
This is the intended behavior as noted above in comment 2 and comment 3
Comment 5 Rohan Kanade 2015-12-09 03:11:07 EST
Hey Jon,

So it means "openstack-rally-0.1.1-4.2.el7ost" rpm is unusable if you do a plain "yum install openstack-rally" and it would require the customer/partner to manually go through steps mentioned in comment 3.


Does the RHELOSP team have official documentation for the steps  mentioned in comment 3 which our customers/partners can follow?
Comment 6 Jon Schlueter 2015-12-09 10:59:55 EST
Openstack-rally is TechPreview in OSP 8 - I don't know that documentation for what steps are needed to make rally work out of the box with a simple yum install.  That should be on the list of items to get completed before GA.

but what is configured and what is enabled and how you use rally needs to be customized for your installation.  Please follow up on bug 1155128 if we have additional needs.

Note You need to log in before you can comment on or make changes to this bug.