Bug 1289620 - need backport of "use correct digest when exporting keying material." from upstream, RFC violation [rhel-7]
need backport of "use correct digest when exporting keying material." from up...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openssl (Show other bugs)
7.2
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Tomas Mraz
Hubert Kario
:
Depends On:
Blocks: 1295396 1296594 1313485 1376741
  Show dependency treegraph
 
Reported: 2015-12-08 10:23 EST by Tim Mooney
Modified: 2017-03-16 11:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: openssl-1.0.1e-56.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1376741 (view as bug list)
Environment:
Last Closed: 2016-11-03 22:04:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Mooney 2015-12-08 10:23:29 EST
Description of problem:

Versions of OpenSSL before 1.0.1h have an issue with incorrect digests when interoperating with certain clients.  It appears that the bug actually causes OpenSSL on RHEL 7 to violate RFC 5246.

The upstream bug report is

    https://rt.openssl.org/Ticket/Display.html?user=guest&pass=guest&id=3319

The one-line patch from upstream that's in 1.0.1h and 1.0.2 is

    https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=4fdf917

Version-Release number of selected component (if applicable):

openssl-1.0.1e-42.el7_1.9
openssl-libs-1.0.1e-42.el7_1.9


Additional info:

This issue can trigger interoperability issues with any client (including devices like mobile phones) that support TLS 1.2 but offer older cipher suites.  Especially on mobile devices, it's often not possible for the user to configure what ciphers their SSL stack prefers.
Comment 7 errata-xmlrpc 2016-11-03 22:04:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2271.html

Note You need to log in before you can comment on or make changes to this bug.