Bug 128965 - Crash on startup when the calendar is open
Crash on startup when the calendar is open
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-02 06:38 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 16:11:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-08-02 06:38:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9.1

Description of problem:
It now crashes when the calendar is open, and won't stop crashing.
I'll have to figure out how to change it back to the mailer being open
(it crashes immediately after startup)

...

calendar-gui-Message: Check if default client matches
(1087975427.3392.4@cobra 1075174343.2225.16@cobra)
calendar-gui-Message: Check if default client matches
(1087975427.3392.4@cobra 1088066939.3733.3@cobra)
calendar-gui-Message: Check if default client matches
(1087975427.3392.4@cobra 1088386875.5824.0@cobra)
calendar-gui-Message: Check if default client matches
(1087975427.3392.4@cobra 1088390779.6800.0@cobra)
[New Thread -227734608 (LWP 31152)]
[New Thread -238224464 (LWP 31153)]
 
calendar-gui-ERROR **: file e-cal-model.c: line 1467 (add_new_client):
assertion failed: (client_data)
aborting...

Program received signal SIGABRT, Aborted.
[Switching to Thread -166649728 (LWP 31128)]
0xf6fe7782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
(gdb) info stack
#0  0xf6fe7782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0xf6234685 in raise () from /lib/tls/libc.so.6
#2  0xf6236099 in abort () from /lib/tls/libc.so.6
#3  0xf635dc3e in g_logv () from /usr/lib/libglib-2.0.so.0
#4  0xf635dc70 in g_log () from /usr/lib/libglib-2.0.so.0
#5  0xf5b77458 in e_cal_model_get_client_for_uri ()
   from /usr/lib/evolution/1.5/components/libevolution-calendar.so
#6  0xf5bbe32f in gnome_calendar_discard_view_popup ()
   from /usr/lib/evolution/1.5/components/libevolution-calendar.so
#7  0xf63d6393 in g_cclosure_marshal_VOID () from
/usr/lib/libgobject-2.0.so.0
#8  0xf63be347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#9  0xf63d394e in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#10 0xf63d59bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#11 0xf63d5c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#12 0xf6edb645 in e_cal_open () from /usr/lib/libecal.so.6
#13 0xf6358818 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#14 0xf63554cb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#15 0xf6356f52 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#16 0xf63571ff in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#17 0xf6c61c45 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#18 0x08063653 in main ()


Version-Release number of selected component (if applicable):
evolution-1.5.91-1

How reproducible:
Always

Steps to Reproduce:
1. See Desc.

Additional info:
Comment 1 Ivan Gyurdiev 2004-08-04 01:29:29 EDT
Evolution kindly went and erased my settings, which I've had to
recover from. I've posted all kinds of bugs regarding this. As a side
effect, the calendar now works. 

Since I can't reproduce the bug anymore, I'm no longer interested. 
Feel free to close it.


Note You need to log in before you can comment on or make changes to this bug.