Bug 1289653 - [Upgrade][Reports] Failed to upgrade rhevm-reports 3.5->3.6
[Upgrade][Reports] Failed to upgrade rhevm-reports 3.5->3.6
Status: CLOSED DUPLICATE of bug 1289660
Product: ovirt-engine-reports
Classification: oVirt
Component: Setup (Show other bugs)
3.6.1
Unspecified Unspecified
unspecified Severity urgent (vote)
: ---
: ---
Assigned To: Shirly Radco
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 11:29 EST by Gil Klein
Modified: 2015-12-08 16:16 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 16:16:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Gil Klein 2015-12-08 11:29:00 EST
Description of problem:

Failed to upgrade rhevm-reports-3.5.x to rhevm-reports-3.6.x

[ INFO  ] Cleaning async tasks and compensations
[ INFO  ] Unlocking existing entities
[ INFO  ] Checking the Engine database consistency
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stopping dwh service
[ INFO  ] Stopping reports service
[ INFO  ] Stopping engine service
[ INFO  ] Stopping ovirt-fence-kdump-listener service
[ INFO  ] Stopping websocket-proxy service
[ INFO  ] Stage: Misc configuration
[ INFO  ] Regenerating Jasper's build configuration files
[ INFO  ] Exporting data out of Jasper
[ ERROR ] Failed to execute stage 'Misc configuration': Command './js-export.sh' failed to execute
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20151208175005-p5xtuv.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20151208180000-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed


Version-Release number of selected component (if applicable):
From: rhevm-reports-3.5.5-2.el6ev.noarch
To: rhevm-reports-setup-3.6.1-1.el6ev.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install RHEV 3.5 with rhevm-reports-3.5.5-2.el6ev.noarch
2. Run engine-config and setup the system
3. Add RHEV 3.6 repos and yum update
4. Run engine-config and trigger the upgrade

Actual results:
rhevm-reports upgrade fails on:
[ ERROR ] Failed to execute stage 'Misc configuration': Command './js-export.sh' failed to execute


Expected results:
rhevm-reports upgrade should succeed  


Additional info:

Caused by: org.postgresql.util.PSQLException: ERROR: relation "jidashboardmodel" does not exist
Comment 1 Gil Klein 2015-12-08 16:16:59 EST

*** This bug has been marked as a duplicate of bug 1289660 ***

Note You need to log in before you can comment on or make changes to this bug.