Bug 1289676 - Scheduled reports generate for last group selected by user when user is a member of multiple groups
Scheduled reports generate for last group selected by user when user is a mem...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.6.0
Assigned To: Libor Pichler
Jiri Stefanisin
: ZStream
Depends On:
Blocks: 1289687 1289688
  Show dependency treegraph
 
Reported: 2015-12-08 12:29 EST by Gregg Tanzillo
Modified: 2016-06-29 11:18 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289687 1289688 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:18:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregg Tanzillo 2015-12-08 12:29:32 EST
When a user schedules a report to run, the schedule record contains the user's ID, but not the group's ID.  When the report actually runs, the group that is used to run the report is based on the last group the user logged in as (as noted above).  Not only does this label that saved report with a potentially different group each time, but the saved report's content is based on the group's RBAC filters, so that means each report might have different content.
Comment 5 errata-xmlrpc 2016-06-29 11:18:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.