Bug 1289677 - Cinder quota class update results in error 'NoneType' object has no attribute '_info
Cinder quota class update results in error 'NoneType' object has no attribute...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cinderclient (Show other bugs)
7.0 (Kilo)
x86_64 Unspecified
unspecified Severity high
: ---
: 7.0 (Kilo)
Assigned To: Eric Harney
lkuchlan
: Reopened, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 12:31 EST by Prasanth Anbalagan
Modified: 2016-08-31 13:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-cinderclient-1.2.1-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-31 13:38:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1423884 None None None Never

  None (edit)
Description Prasanth Anbalagan 2015-12-08 12:31:30 EST
***********************
Description of problem:
***********************

Cinder quota class update results in error "ERROR: 'NoneType' object has no attribute '_info', but the show command does list the new value.

****************
Version-Release 
****************

[root@seal17 ~(keystone_admin)]# yum list installed | grep openstack-cinder
openstack-cinder.noarch              2015.1.2-4.el7ost       @rhelosp-7.0-puddle

*****************
How reproducible:
*****************

Always

*******************
Steps to Reproduce:
*******************

1. cinder quota-class-update --volumes 10000 admin
2. Error message- "ERROR: 'NoneType' object has no attribute '_info"

****************
Actual results:
****************


[root@seal17 ~(keystone_admin)]# cinder quota-class-update --volumes 10000 admin
ERROR: 'NoneType' object has no attribute '_info'
[root@seal17 ~(keystone_admin)]# cinder quota-class-update --volumes 10000 demo
ERROR: 'NoneType' object has no attribute '_info'
[root@seal17 ~(keystone_admin)]# cinder quota-class-update --volumes 10000 services
ERROR: 'NoneType' object has no attribute '_info'

*****************
quota class show
*****************

root@seal17 ~(keystone_admin)]# cinder quota-class-show admin
+------------------+-------+
|     Property     | Value |
+------------------+-------+
| backup_gigabytes |  1000 |
|     backups      |   10  |
|    gigabytes     |  1000 |
| gigabytes_iscsi  |   -1  |
|    snapshots     |   10  |
| snapshots_iscsi  |   -1  |
|     volumes      | 10000 |
|  volumes_iscsi   |   -1  |
+------------------+-------+
[root@seal17 ~(keystone_admin)]# cinder quota-class-show demo
+------------------+-------+
|     Property     | Value |
+------------------+-------+
| backup_gigabytes |  1000 |
|     backups      |   10  |
|    gigabytes     |  1000 |
| gigabytes_iscsi  |   -1  |
|    snapshots     |   10  |
| snapshots_iscsi  |   -1  |
|     volumes      | 10000 |
|  volumes_iscsi   |   -1  |
+------------------+-------+
[root@seal17 ~(keystone_admin)]# cinder quota-class-show services
+------------------+-------+
|     Property     | Value |
+------------------+-------+
| backup_gigabytes |  1000 |
|     backups      |   10  |
|    gigabytes     |  1000 |
| gigabytes_iscsi  |   -1  |
|    snapshots     |   10  |
| snapshots_iscsi  |   -1  |
|     volumes      | 10000 |
|  volumes_iscsi   |   -1  |
+------------------+-------+


******************
Expected results:
*****************

No error message
Comment 2 Eric Harney 2015-12-08 15:03:43 EST
Reproduced:

[root@dhcp148-170 ~(keystone_admin)]# rpm -q python-cinderclient
python-cinderclient-1.2.1-1.el7ost.noarch
[root@dhcp148-170 ~(keystone_admin)]# cinder quota-class-update --volumes 10000 admin
ERROR: 'NoneType' object has no attribute '_info'
Comment 3 Eric Harney 2015-12-08 15:05:53 EST
# OS_VOLUME_API_VERSION=2 cinder quota-class-update --volumes 10000 admin
ERROR: 'Namespace' object has no attribute 'class_name'
# OS_VOLUME_API_VERSION=1 cinder quota-class-update --volumes 10000 admin
ERROR: 'NoneType' object has no attribute '_info'
Comment 4 Eric Harney 2015-12-08 15:34:13 EST
Appears to be fixed in upstream 1.3.1.
Comment 5 Sergey Gotliv 2015-12-15 08:44:09 EST
Close base on comment #3.
Comment 7 lkuchlan 2016-08-01 08:52:07 EDT
Tested using:
openstack-cinder-2015.1.3-7.el7ost.noarch
python-cinderclient-1.2.1-3.el7ost.noarch
python-cinder-2015.1.3-7.el7ost.noarch

Verification flow:

[root@cougar15 ~(keystone_admin)]# cinder quota-class-show admin
+------------------+-------+
|     Property     | Value |
+------------------+-------+
| backup_gigabytes |  1000 |                                                                                                                                                                                       
|     backups      |   10  |                                                                                                                                                                                       
|    gigabytes     |  1000 |                                                                                                                                                                                       
| gigabytes_iscsi  |   -1  |                                                                                                                                                                                       
|    snapshots     |   10  |                                                                                                                                                                                       
| snapshots_iscsi  |   -1  |                                                                                                                                                                                       
|     volumes      |   10  |                                                                                                                                                                                       
|  volumes_iscsi   |   -1  |                                                                                                                                                                                       
+------------------+-------+                                                                                                                                                                                       
[root@cougar15 ~(keystone_admin)]# cinder quota-class-update --volumes 100 admin
+------------------+-------+                                                                                                                                                                                       
|     Property     | Value |                                                                                                                                                                                       
+------------------+-------+                                                                                                                                                                                       
| backup_gigabytes |  1000 |                                                                                                                                                                                       
|     backups      |   10  |                                                                                                                                                                                       
|    gigabytes     |  1000 |                                                                                                                                                                                       
| gigabytes_iscsi  |   -1  |                                                                                                                                                                                       
|    snapshots     |   10  |
| snapshots_iscsi  |   -1  |
|     volumes      |  100  |
|  volumes_iscsi   |   -1  |
+------------------+-------+
Comment 9 errata-xmlrpc 2016-08-31 13:38:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1791.html

Note You need to log in before you can comment on or make changes to this bug.