Bug 1289679 - sos netstat capture truncates IPV6 addresses
sos netstat capture truncates IPV6 addresses
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Pavel Moravec
Miroslav Hradílek
https://github.com/sosreport/sos/issu...
:
Depends On:
Blocks: 1298112 1313485 1381991
  Show dependency treegraph
 
Reported: 2015-12-08 12:39 EST by Martin Poole
Modified: 2016-11-04 00:55 EDT (History)
9 users (show)

See Also:
Fixed In Version: sos-3.3-0.el7
Doc Type: Bug Fix
Doc Text:
Prior to this update, the collected netstat output truncated IPv6 addresses, preventing users to see complete IP address of listed connections. With this update, the gathered command prints output in a wide format, thus with complete IPv6 addresses.
Story Points: ---
Clone Of:
: 1381991 (view as bug list)
Environment:
Last Closed: 2016-11-04 00:55:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2015-12-08 12:39:01 EST
Description of problem:

netstat -neopa data truncates IPV6 addresses

Version-Release number of selected component (if applicable):

sos-3.2-35.el7

Additional info:

command needs additional of -T to ensure full addresses are captured.
Comment 1 Bryn M. Reeves 2015-12-08 12:58:26 EST
Really?

-T is not documented in the netstat man page or usage text and attempting to add it causes an invalid option error:

    [root@bmr-rhel7-vm1 ~]# netstat -neopaT
    netstat: invalid option -- 'T'
    usage: netstat [-vWeenNcCF] [<Af>] -r         netstat {-V|--version|-
    h|--help}
           netstat [-vWnNcaeol] [<Socket> ...]
           netstat { [-vWeenNac] -I[<Iface>] | [-veenNac] -i | [-cnNe] -M | -s 
           [-6tuw] } [delay]
[...]

None of the netstats on my Fedora or RHEL boxes have heard of this switch.

# rpm -q net-tools
net-tools-2.0-0.17.20131004git.el7.x86_64

Is this a new option? If so we'd need to know what version it appears in in order to not trigger errors on older installations (although to be honest the idea of a "please don't trash IP addresses on output" switch to a net-tools command seems a bit crazy just out the gate..).

It would also be helpful if you could include full steps to reproduce or the output that you are seeing - I don't see any truncation when running this command with the default IPv6 settings on an el7 install.
Comment 2 Martin Poole 2015-12-08 13:06:50 EST
Oh joy.

On RHEL7 it's -W, on RHEL6 and earlier it's -T
Comment 4 Pavel Moravec 2016-02-21 07:18:55 EST
posted to upstream:

606dcbc7d1cc203487ae9e773fe7173aa1966f2c
aa7fd5739f528cd9534fb4d86daff0e7c0e9bd06
Comment 6 Mike McCune 2016-03-28 19:20:28 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 10 errata-xmlrpc 2016-11-04 00:55:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2380.html

Note You need to log in before you can comment on or make changes to this bug.