Bug 1289681 - VolumeLimitExceeded error even though quota is updated to larger value
VolumeLimitExceeded error even though quota is updated to larger value
Status: CLOSED WORKSFORME
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: Eric Harney
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 12:44 EST by Prasanth Anbalagan
Modified: 2016-04-26 20:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 12:38:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanth Anbalagan 2015-12-08 12:44:24 EST
************
Description
************

"VolumeLimitExceeded:Maximum number of volumes allowed (10) exceeded" error observed even though the cinder
quota has been updated to 10000 volumes.

********
Version
********

[root@seal17 ~(keystone_admin)]# yum list installed | grep openstack-cinder
openstack-cinder.noarch              2015.1.2-4.el7ost       @rhelosp-7.0-puddle

*******************
Steps to reproduce
*******************

1) Update quota using the following commands
   cinder quota-update  --volumes 10000 <tenant-id for admin/demo/services>
   cinder quota-class-update --volumes 10000 <admin/demo/services>

2) openstack-service restart cinder

3) Check that the quota values have been updated.

[root@seal17 ~(keystone_admin)]# cinder quota-show  admin
+------------------+-------+
|     Property     | Value |
+------------------+-------+
| backup_gigabytes |  1000 |
|     backups      |   10  |
|    gigabytes     |  1000 |
| gigabytes_iscsi  |   -1  |
|    snapshots     |   10  |
| snapshots_iscsi  |   -1  |
|     volumes      | 10000 |
|  volumes_iscsi   |   -1  |
+------------------+-------+
[root@seal17 ~(keystone_admin)]# 
[root@seal17 ~(keystone_admin)]# cinder quota-show  demo
+------------------+-------+
|     Property     | Value |
+------------------+-------+
| backup_gigabytes |  1000 |
|     backups      |   10  |
|    gigabytes     |  1000 |
| gigabytes_iscsi  |   -1  |
|    snapshots     |   10  |
| snapshots_iscsi  |   -1  |
|     volumes      | 10000 |
|  volumes_iscsi   |   -1  |
+------------------+-------+
[root@seal17 ~(keystone_admin)]# cinder quota-show  services
+------------------+-------+
|     Property     | Value |
+------------------+-------+
| backup_gigabytes |  1000 |
|     backups      |   10  |
|    gigabytes     |  1000 |
| gigabytes_iscsi  |   -1  |
|    snapshots     |   10  |
| snapshots_iscsi  |   -1  |
|     volumes      | 10000 |
|  volumes_iscsi   |   -1  |
+------------------+-------+
[root@seal17 ~(keystone_admin)]# 
[root@seal17 ~(keystone_admin)]# cinder quota-class-show  admin
+------------------+-------+
|     Property     | Value |
+------------------+-------+
| backup_gigabytes |  1000 |
|     backups      |   10  |
|    gigabytes     |  1000 |
| gigabytes_iscsi  |   -1  |
|    snapshots     |   10  |
| snapshots_iscsi  |   -1  |
|     volumes      | 10000 |
|  volumes_iscsi   |   -1  |
+------------------+-------+
[root@seal17 ~(keystone_admin)]# cinder quota-class-show  demo
+------------------+-------+
|     Property     | Value |
+------------------+-------+
| backup_gigabytes |  1000 |
|     backups      |   10  |
|    gigabytes     |  1000 |
| gigabytes_iscsi  |   -1  |
|    snapshots     |   10  |
| snapshots_iscsi  |   -1  |
|     volumes      | 10000 |
|  volumes_iscsi   |   -1  |
+------------------+-------+
[root@seal17 ~(keystone_admin)]# cinder quota-class-show services
+------------------+-------+
|     Property     | Value |
+------------------+-------+
| backup_gigabytes |  1000 |
|     backups      |   10  |
|    gigabytes     |  1000 |
| gigabytes_iscsi  |   -1  |
|    snapshots     |   10  |
| snapshots_iscsi  |   -1  |
|     volumes      | 10000 |
|  volumes_iscsi   |   -1  |
+------------------+-------+
[root@seal17 ~(keystone_admin)]# 
[root@seal17 ~(keystone_admin)]# 

4) Create 10 volumes ( or old limit number)
[root@seal17 ~(keystone_admin)]# cinder list
+--------------------------------------+-----------+--------------+------+-------------+----------+--------------------------------------+
|                  ID                  |   Status  | Display Name | Size | Volume Type | Bootable |             Attached to              |
+--------------------------------------+-----------+--------------+------+-------------+----------+--------------------------------------+
| 0664d5bf-c159-470c-8ef9-325e2afb405e | available |    t6vol1    |  1   |      -      |  false   |                                      |
| 156fdd02-00ca-427e-a7be-4ca245f352d5 |   in-use  |     vol1     |  1   |      -      |  false   | 6e56ec06-3287-4d02-90db-69905ecda71f |
| 2b2d1e6a-7be1-407c-bfea-20c5ce8d853d | available |    t4vol1    |  1   |      -      |  false   |                                      |
| 3eb23ddf-9c33-4d46-b9a1-25ffcaf8c888 | available |    t3vol1    |  1   |      -      |  false   |                                      |
| 54cb660a-2b11-4322-a662-9104d612eb76 | available |    t0vol1    |  1   |      -      |  false   |                                      |
| 8b612ec0-524d-4876-9609-b04dc63f3891 | available |    t8vol1    |  1   |      -      |  false   |                                      |
| 95165dcb-d3cf-4e58-86aa-e2ed4859299f | available |    t5vol1    |  1   |      -      |  false   |                                      |
| 9c525949-b4af-4d61-91a5-69072604852d | available |    t1vol1    |  1   |      -      |  false   |                                      |
| c3df32f7-a1de-47a2-9589-b448f9c22a00 | available |    t2vol1    |  1   |      -      |  false   |                                      |
| f408af10-1bdf-4102-8fd5-86a915950835 | available |    t9vol1    |  1   |      -      |  false   |                                      |
+--------------------------------------+-----------+--------------+------+-------------+----------+--------------------------------------+
[root@seal17 ~(keystone_admin)]# 
[root@seal17 ~(keystone_admin)]#

5) Try exceeding the old limit value and error will be observed.
 
[root@seal17 ~(keystone_admin)]# cinder create --display-name vol2 1
ERROR: VolumeLimitExceeded: Maximum number of volumes allowed (10) exceeded (HTTP 413) (Request-ID: req-2bc25450-0fce-4ad0-a2f0-5d44203eeb16)
[root@seal17 ~(keystone_admin)]#
Comment 2 Sergey Gotliv 2015-12-10 08:11:22 EST
Prasanth,

Do you still have that environment?
Comment 4 Prasanth Anbalagan 2015-12-14 12:38:28 EST
The issue is no longer seen on the system. So closing the bug for now.

Note You need to log in before you can comment on or make changes to this bug.