Bug 1289685 - funcsigs and pbr dependencies are missing
funcsigs and pbr dependencies are missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-mock (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Praveen Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 12:50 EST by Fabio Alessandro Locati
Modified: 2016-02-09 05:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 05:58:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Alessandro Locati 2015-12-08 12:50:32 EST
Description of problem:
It seems like python-mock has some problems with dependencies

Version-Release number of selected component (if applicable):


How reproducible:
following the following steps

Steps to Reproduce:
1. dnf install letsencrypt (but probably any other mock based program works)
2. execute it

Actual results:
fale@x250:~/Downloads $ letsencrypt
Traceback (most recent call last):
  File "/usr/bin/letsencrypt", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 651, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 952, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'funcsigs' distribution was not found and is required by mock

Expected results:
to have it working

Additional info:
I've tried to install funcsigs via pip, but then it complained about pbr>=0.11. Installing this one too, it worked properly
Comment 1 James Hogarth 2015-12-08 12:57:14 EST
My Fedora server installed python-mock as a dependency of letsencrypt and it worked fine though and I confirmed that there was no output from rpm -qa \*funcsigs\* on my system...

You might want to confirm for sure where your mock has come from...

Does rpm -qV python-mock have any output?
Comment 2 Fabio Alessandro Locati 2015-12-08 13:08:43 EST
fale@x250:~ $ rpm -qV python-mock
fale@x250:~ $ rpm -qa | grep python-mock
python-mock-1.0.1-5.fc23.noarch
Comment 3 Robert Buchholz 2015-12-10 13:24:25 EST
I've verified installation works on a clean fedora 23 image (downloaded a cloud image, updated it, installed letsencrypt).

Is it possible you installed something into your OS-managed python site-packages directory by running "pip" outside a virtualenv as root?

Hint: you can check this a bit crudely like so:
find /usr/lib64/python2.7/site-packages/ -maxdepth 1 -print0 | xargs -0 -n 1 rpm -qf  | grep "not owned"
Comment 4 Fabio Alessandro Locati 2015-12-10 14:22:10 EST
fale@x250:~ $ find /usr/lib64/python2.7/site-packages/ -maxdepth 1 -print0 | xargs -0 -n 1 rpm -qf  | grep "not owned"
fale@x250:~ $

It seems like nothing comes out.

It's possible I've used pip outside a virtualenv as root.
Comment 5 Fabio Alessandro Locati 2016-02-09 05:58:34 EST
I'm not able to reproduce this bug so probably I had a dirty environment

Note You need to log in before you can comment on or make changes to this bug.