Bug 1289696 - tzdata: Perform /etc/localtime updates
tzdata: Perform /etc/localtime updates
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tzdata (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Patsy Franklin
qe-baseos-daemons
:
Depends On:
Blocks: 1200555 1292833
  Show dependency treegraph
 
Reported: 2015-12-08 13:13 EST by Florian Weimer
Modified: 2016-04-28 14:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: tzdata-2015g-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1292833 (view as bug list)
Environment:
Last Closed: 2016-04-28 14:59:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2015-12-08 13:13:03 EST
To fix bug 1200555, we need to change the /etc/localtime update mechanism not to touch /etc/localtime if it s a symbolic link.  This is difficult to implement within the existing statically-linked /usr/sbin/tzdata-update program.

With RHEL 6 RPM, it is possible to implement /etc/localtime updates with Lua interpreter built into RPM, including the symbolic link check.  This means that the dependency issue which previously stopped us to include the /etc/localtime management in the tzdata package do not apply anymore, and we can perform the update in a %post scriptlet written in Lua.

We need tzdata packages with this change for testing the fix for bug 1200555, but there is no need to actually release these packages at the same time the fix for bug 1200555 goes out.  The reason is that /etc/localtime needs to be updated only at tzdata update time.

Note You need to log in before you can comment on or make changes to this bug.