Bug 1289703 - UI: Automate Explorer - Domain version message should say "Current version" instead of "Currently version"
UI: Automate Explorer - Domain version message should say "Current version" i...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Harpreet Kataria
amogh
: ZStream
Depends On:
Blocks: 1289706
  Show dependency treegraph
 
Reported: 2015-12-08 13:26 EST by Harpreet Kataria
Modified: 2016-06-29 11:18 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289706 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:18:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Domain version message (58.39 KB, image/png)
2015-12-08 13:26 EST, Harpreet Kataria
no flags Details
current_domain_version (114.84 KB, image/png)
2016-04-27 17:55 EDT, amogh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 14:50:04 EDT

  None (edit)
Description Harpreet Kataria 2015-12-08 13:26:40 EST
Created attachment 1103662 [details]
Domain version message

Description of problem: UI: Automate Explorer - Domain version message should say "Current version" instead of "Currently version"


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Go to Automate explorer
2. If current running version is different than available version for Automate domain, it should display a message on the screen with Domain version information.
3. Domain version message needs to be fixed to say "xx domain: Current version - xx, Available version - xx"

Actual results: Message wording: "xx domain: Currently version - xx, Available version - xx"


Expected results: "xx domain: Current version - xx, Available version - xx"


Additional info:
Comment 2 Harpreet Kataria 2015-12-09 09:52:40 EST
https://github.com/ManageIQ/manageiq/pull/5770
Comment 3 CFME Bot 2015-12-09 11:25:28 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/6d38118970c53b957a4c0795cc40fbdec475c601

commit 6d38118970c53b957a4c0795cc40fbdec475c601
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Dec 9 09:51:02 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Dec 9 09:51:02 2015 -0500

    Fixed wording of Domain version message
    
    Changed from "xx domain: Currently version - xx, Available version - xx" to "xx domain: Current version - xx, Available version - xx"
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289703
    https://bugzilla.redhat.com/show_bug.cgi?id=1289706

 app/controllers/miq_ae_class_controller.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 5 CFME Bot 2015-12-09 14:43:14 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=dea59fa1357f0c8166f572d5f96e0b94cc2a2588

commit dea59fa1357f0c8166f572d5f96e0b94cc2a2588
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Dec 9 09:51:02 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Dec 9 12:23:09 2015 -0500

    Fixed wording of Domain version message
    
    Changed from "xx domain: Currently version - xx, Available version - xx" to "xx domain: Current version - xx, Available version - xx"
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289703
    https://bugzilla.redhat.com/show_bug.cgi?id=1289706
    (cherry picked from commit 6d38118)

 app/controllers/miq_ae_class_controller.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 6 CFME Bot 2015-12-09 14:43:23 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=4c83344a9cefe9768624b2e7f2f10653bc42bf46

commit 4c83344a9cefe9768624b2e7f2f10653bc42bf46
Merge: a0403d3 dea59fa
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Dec 9 14:40:00 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Dec 9 14:40:00 2015 -0500

    Merge branch '55z_pr_5770' into '5.5.z'
    
    Fixed wording of Domain version message
    
    Changed from "xx domain: Currently version - xx, Available version - xx" to "xx domain: Current version - xx, Available version - xx"
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289703
    https://bugzilla.redhat.com/show_bug.cgi?id=1289706
    (cherry picked from commit 6d38118)
    
    @dclarizi this is a clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/5770
    
    See merge request !606

 app/controllers/miq_ae_class_controller.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 7 amogh 2016-04-27 17:55:27 EDT
verified this bug in 5.6.0.4-beta2.3.20160421172650_719e256 and it is not reproducible.

1. launch the appliance, deleted the existing domain.
2. imported the "RedHat" domain from older version, upload successful.
3. click on "Automate->explorer->Datastore->RedHat" "RedHat domain: Current version - 5.5.2.4, Available version - 5.6.0.4" is displayed.

refer the screenshot "current_domain_version"
Comment 8 amogh 2016-04-27 17:55 EDT
Created attachment 1151631 [details]
current_domain_version
Comment 10 errata-xmlrpc 2016-06-29 11:18:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.