Bug 128974 - Dependency to libselinux(-devel) even if SELinux is disabled
Dependency to libselinux(-devel) even if SELinux is disabled
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-02 11:06 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 12:50:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-08-02 11:06:37 EDT
Description of problem:
Dependency to libselinux(-devel) even if SELinux is disabled at 
rebuilding time:

--- snipp ---
# rpmbuild -ba shadow-utils.spec
error: Failed build dependencies:
        libselinux-devel is needed by shadow-utils-4.0.3-25
#
--- snapp ---

Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-24

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. Set "%define WITH_SELINUX 0"
2. rpmbuild -ba shadow-utils.spec
3. Get the dependency error
  
Actual results:
Dependency to libselinux(-devel) even if SELinux is disabled.

Expected results:
Dependency to libselinux(-devel) only if SELinux is enabled; the 
following change solves it for me:

--- snipp ---
--- shadow-utils.spec       2004-08-02 01:36:29.000000000 +0200
+++ shadow-utils.spec.rsc   2004-08-02 17:07:11.000000000 +0200
@@ -34,8 +34,10 @@
 License: BSD
 Group: System Environment/Base
 BuildPrereq: autoconf, automake, libtool, gettext
+%if %{WITH_SELINUX}
 BuildRequires: libselinux-devel
 Requires: libselinux
+%endif
 Buildroot: %{_tmppath}/%{name}-%{version}-root
 Obsoletes: adduser

--- snapp ---
Comment 1 Robert Scheck 2004-10-01 12:50:11 EDT
I think, this bug report isn't any longer of belong, because Fedora 
Core 3 will have SELinux support; closing with "wontfix" now.

Note You need to log in before you can comment on or make changes to this bug.