Bug 1289765 - Missing data model objects in editors (unable to add to path)
Missing data model objects in editors (unable to add to path)
Status: CLOSED DUPLICATE of bug 1289758
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: manstis
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 17:34 EST by Eric D. Schabell
Modified: 2015-12-09 03:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-09 03:53:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric D. Schabell 2015-12-08 17:34:29 EST
Description of problem: (same bug as found on BPM Suite https://bugzilla.redhat.com/show_bug.cgi?id=1289758, screenshots attached there apply to BRMS as well)

Install bpms-install-demo project for arms 6.2.0.GA, start server, login, follow steps from workshop starting:

http://bpmworkshop-onthe.rhcloud.com/brms6_1/lab02.html#/3

Note screenshots are from 6.1 product, but create unmanaged project and follow along until you hit:

http://bpmworkshop-onthe.rhcloud.com/brms6_1/lab03.html#/3

Now create data object:

 - Product with id attribute at package level com.redhat.coolstore no persistence checked and save.

First issue, notice (see screenshot attached in https://bugzilla.redhat.com/show_bug.cgi?id=1289758), can't select Default package level, just com, com.redhat or com.redhat.coolstore. 

Now create data object:

 - ShoppingCart with id attribute at package level com.redhat no persistence checked and save.

Now create guided rule:

 - TestRule at package level Default (note you have Default package level now) no DSL
 - select Config tab, Add Import button, pull down shows only Product object, Integer and Number, see attached screenshot in https://bugzilla.redhat.com/show_bug.cgi?id=1289758.

Second issue, should show all data objects.

Now back to guided rule Editor tab, click on WHEN plus icon, only see Number, see attached screenshot in https://bugzilla.redhat.com/show_bug.cgi?id=1289758.

Third issue, don't expect any data objects, but why only Number available for use in rule, hard to build a rule. 

Same for DRL, Forms, Guided Decision Table, Guided Decision Tree, etc. All that allow for import of data objects fails to find in project.

All encountered using this workshop: http://bpmworkshop-onthe.rhcloud.com/brms6_1/lab01.html but with BRMS 6.2.0.GA to test product.

Version-Release number of selected component (if applicable): 6.2.0.GA


How reproducible: see above.


Steps to Reproduce:
1. see above
2.
3.

Actual results: no data objects available for import when in project.


Expected results: data objects in project available for import.


Additional info:
attached screenshots in https://bugzilla.redhat.com/show_bug.cgi?id=1289758
Comment 1 Eric D. Schabell 2015-12-08 17:38:35 EST
One correction to bug description, this was tested with bras-install-demo project for BRMS 6.2.0.GA: https://github.com/jbossdemocentral/brms-install-demo
Comment 3 Zuzana Krejčová 2015-12-09 03:53:01 EST

*** This bug has been marked as a duplicate of bug 1289758 ***

Note You need to log in before you can comment on or make changes to this bug.