Bug 1289782 - With latest update note plasmoid is transparent
Summary: With latest update note plasmoid is transparent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kf5-plasma
Version: 23
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-09 00:03 UTC by Elia Devito
Modified: 2015-12-11 23:50 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-11 23:50:29 UTC


Attachments (Terms of Use)
note plasmoid have transparent background (274.70 KB, image/png)
2015-12-09 00:03 UTC, Elia Devito
no flags Details
like it should be (28.89 KB, image/png)
2015-12-09 18:24 UTC, Elia Devito
no flags Details
like it really is (76.56 KB, image/png)
2015-12-09 18:25 UTC, Elia Devito
no flags Details
plasma widget explorer missing icons (85.79 KB, image/png)
2015-12-09 18:29 UTC, Elia Devito
no flags Details

Description Elia Devito 2015-12-09 00:03:32 UTC
Created attachment 1103744 [details]
note plasmoid have transparent background

Description of problem:
With latest update (plasma 5.5.0 testing) some plasmoids have transparent background and are not resizable

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to latest plasma 5.5.0 from testing repo

Actual results:
Some plasmoids have transparent background.
All plasmoid are not resizable

Expected results:
plasmoids have correct background and are resizable

Additional info:
I have noted this issue on two PC

Comment 1 Rex Dieter 2015-12-09 01:45:38 UTC
resizing method changed to click-n-hold, rather than hover... in 5.5

If you want to switch back to the older way, right click Desktop -> Desktop/FolderView settings -> tweaks -> (uncheck) Press and hold widgets to move htem and reveal their handles


Can't speak for the background issue, can you be more specific?

Comment 2 Elia Devito 2015-12-09 18:23:21 UTC
Thanks, I was not aware of the change.

The plasmoid issue contrary to what I said previously the problem occur only with note plasmoid (sorry for imprecision).
Pratically if I add a note plasmoid on my desktop it appears but is transparent, instead it should be colored.

another thing that I have noted is that in the plasma widget explorer some icons are missing

Comment 3 Elia Devito 2015-12-09 18:24:39 UTC
Created attachment 1104067 [details]
like it should be

Comment 4 Elia Devito 2015-12-09 18:25:49 UTC
Created attachment 1104068 [details]
like it really is

Comment 5 Elia Devito 2015-12-09 18:29:33 UTC
Created attachment 1104069 [details]
plasma widget explorer missing icons

Comment 6 Elia Devito 2015-12-09 19:04:53 UTC
downgrade to kdeplasma-addons-5.4.3-1.fc23.x86_64 resolve the problem.

kdeplasma-addons-5.5.0 bug?

Comment 7 Rex Dieter 2015-12-09 19:12:25 UTC
Apparently so, I'd suggest contacting upstream @ bugs.kde.org

Comment 8 Elia Devito 2015-12-10 16:21:30 UTC
I have found the cause of problem, in the kdeplasma-addons 5.5.0 the file notes.svgz missing because it's moved to kf5-plasma package.

You can see this here:
https://quickgit.kde.org/?p=kdeplasma-addons.git&a=commit&h=d52e64f5e87d134326cc64fe861716d341a3abc3

https://quickgit.kde.org/?p=plasma-framework.git&a=commit&h=862dac430468ebfa6aa9b8bb1b3bc83441405795

notes.svgz isn't part of kdeplasma-addons since 5.5.0 but is part of kf5-plasma since 5.17.0 (not released yet)

In my opinion the possible solutions for this issue are:
 - Wait release of kf5-plasma 5.17.0
 - Backport notes.svgz to kf5-plasma-5.16.0

Comment 9 Rex Dieter 2015-12-10 16:22:59 UTC
Thanks, we can probably find some way of fixing this (or just waiting for kf5-5.17 to land, work is underway)

Comment 10 Fedora Update System 2015-12-10 17:55:42 UTC
bluedevil-5.5.0-1.fc23 breeze-gtk-5.5.0.1-1.fc23 kde-cli-tools-5.5.0-1.fc23 kde-gtk-config-5.5.0-1.fc23 kde-l10n-15.08.3-1.fc23 kdecoration-5.5.0-1.fc23 kdeplasma-addons-5.5.0-2.fc23 kf5-kwayland-5.5.0-1.fc23 kgamma-5.5.0-1.fc23 khelpcenter-5.5.0-1.fc23 khotkeys-5.5.0-1.fc23 kinfocenter-5.5.0-1.fc23 kmenuedit-5.5.0-1.fc23 kscreen-5.5.0-1.fc23 kscreenlocker-5.5.0-1.fc23 ksshaskpass-5.5.0-1.fc23 ksysguard-5.5.0-1.fc23 kwayland-integration-5.5.0-1.fc23 kwin-5.5.0-1.fc23 kwrited-5.5.0-1.fc23 libkscreen-qt5-5.5.0-1.fc23 libksysguard-5.5.0-1.fc23 muon-5.5.0-1.fc23 pam-kwallet-5.5.0-1.fc23 plasma-breeze-5.5.0-1.fc23 plasma-desktop-5.5.0-4.fc23 plasma-mediacenter-5.5.0-1.fc23 plasma-milou-5.5.0-1.fc23 plasma-nm-5.5.0-1.fc23 plasma-oxygen-5.5.0-1.fc23 plasma-pa-5.5.0-1.fc23 plasma-sdk-5.5.0-1.fc23 plasma-systemsettings-5.5.0-1.fc23 plasma-workspace-5.5.0-2.fc23 polkit-kde-5.5.0-1.fc23 powerdevil-5.5.0-1.fc23 sddm-kcm-5.5.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0f88189b65

Comment 11 Fedora Update System 2015-12-10 17:55:55 UTC
bluedevil-5.5.0-1.fc23 breeze-gtk-5.5.0.1-1.fc23 kde-cli-tools-5.5.0-1.fc23 kde-gtk-config-5.5.0-1.fc23 kde-l10n-15.08.3-1.fc23 kdecoration-5.5.0-1.fc23 kdeplasma-addons-5.5.0-2.fc23 kf5-kwayland-5.5.0-1.fc23 kgamma-5.5.0-1.fc23 khelpcenter-5.5.0-1.fc23 khotkeys-5.5.0-1.fc23 kinfocenter-5.5.0-1.fc23 kmenuedit-5.5.0-1.fc23 kscreen-5.5.0-1.fc23 kscreenlocker-5.5.0-1.fc23 ksshaskpass-5.5.0-1.fc23 ksysguard-5.5.0-1.fc23 kwayland-integration-5.5.0-1.fc23 kwin-5.5.0-1.fc23 kwrited-5.5.0-1.fc23 libkscreen-qt5-5.5.0-1.fc23 libksysguard-5.5.0-1.fc23 muon-5.5.0-1.fc23 pam-kwallet-5.5.0-1.fc23 plasma-breeze-5.5.0-1.fc23 plasma-desktop-5.5.0-4.fc23 plasma-mediacenter-5.5.0-1.fc23 plasma-milou-5.5.0-1.fc23 plasma-nm-5.5.0-1.fc23 plasma-oxygen-5.5.0-1.fc23 plasma-pa-5.5.0-1.fc23 plasma-sdk-5.5.0-1.fc23 plasma-systemsettings-5.5.0-1.fc23 plasma-workspace-5.5.0-2.fc23 polkit-kde-5.5.0-1.fc23 powerdevil-5.5.0-1.fc23 sddm-kcm-5.5.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0f88189b65

Comment 12 Fedora Update System 2015-12-11 06:02:37 UTC
bluedevil-5.5.0-1.fc23, breeze-gtk-5.5.0.1-1.fc23, kde-cli-tools-5.5.0-1.fc23, kde-gtk-config-5.5.0-1.fc23, kde-l10n-15.08.3-1.fc23, kdecoration-5.5.0-1.fc23, kdeplasma-addons-5.5.0-2.fc23, kf5-kwayland-5.5.0-1.fc23, kgamma-5.5.0-1.fc23, khelpcenter-5.5.0-1.fc23, khotkeys-5.5.0-1.fc23, kinfocenter-5.5.0-1.fc23, kmenuedit-5.5.0-1.fc23, kscreen-5.5.0-1.fc23, kscreenlocker-5.5.0-1.fc23, ksshaskpass-5.5.0-1.fc23, ksysguard-5.5.0-1.fc23, kwayland-integration-5.5.0-1.fc23, kwin-5.5.0-1.fc23, kwrited-5.5.0-1.fc23, libkscreen-qt5-5.5.0-1.fc23, libksysguard-5.5.0-1.fc23, muon-5.5.0-1.fc23, pam-kwallet-5.5.0-1.fc23, plasma-breeze-5.5.0-1.fc23, plasma-desktop-5.5.0-4.fc23, plasma-mediacenter-5.5.0-1.fc23, plasma-milou-5.5.0-1.fc23, plasma-nm-5.5.0-1.fc23, plasma-oxygen-5.5.0-1.fc23, plasma-pa-5.5.0-1.fc23, plasma-sdk-5.5.0-1.fc23, plasma-systemsettings-5.5.0-1.fc23, plasma-workspace-5.5.0-2.fc23, polkit-kde-5.5.0-1.fc23, powerdevil-5.5.0-1.fc23, sddm-kcm-5.5.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kdeplasma-addons breeze-gtk plasma-desktop kde-gtk-config pam-kwallet kde-l10n kscreenlocker kwrited plasma-milou kdecoration plasma-breeze ksysguard kgamma kf5-kwayland kinfocenter bluedevil kwayland-integration kscreen plasma-mediacenter ksshaskpass kde-cli-tools libksysguard plasma-nm plasma-workspace plasma-oxygen powerdevil plasma-sdk khelpcenter muon plasma-systemsettings khotkeys kmenuedit libkscreen-qt5 kwin plasma-pa polkit-kde sddm-kcm'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0f88189b65

Comment 13 Fedora Update System 2015-12-11 23:50:18 UTC
bluedevil-5.5.0-1.fc23, breeze-gtk-5.5.0.1-1.fc23, kde-cli-tools-5.5.0-1.fc23, kde-gtk-config-5.5.0-1.fc23, kde-l10n-15.08.3-1.fc23, kdecoration-5.5.0-1.fc23, kdeplasma-addons-5.5.0-2.fc23, kf5-kwayland-5.5.0-1.fc23, kgamma-5.5.0-1.fc23, khelpcenter-5.5.0-1.fc23, khotkeys-5.5.0-1.fc23, kinfocenter-5.5.0-1.fc23, kmenuedit-5.5.0-1.fc23, kscreen-5.5.0-1.fc23, kscreenlocker-5.5.0-1.fc23, ksshaskpass-5.5.0-1.fc23, ksysguard-5.5.0-1.fc23, kwayland-integration-5.5.0-1.fc23, kwin-5.5.0-1.fc23, kwrited-5.5.0-1.fc23, libkscreen-qt5-5.5.0-1.fc23, libksysguard-5.5.0-1.fc23, muon-5.5.0-1.fc23, pam-kwallet-5.5.0-1.fc23, plasma-breeze-5.5.0-1.fc23, plasma-desktop-5.5.0-4.fc23, plasma-mediacenter-5.5.0-1.fc23, plasma-milou-5.5.0-1.fc23, plasma-nm-5.5.0-1.fc23, plasma-oxygen-5.5.0-1.fc23, plasma-pa-5.5.0-1.fc23, plasma-sdk-5.5.0-1.fc23, plasma-systemsettings-5.5.0-1.fc23, plasma-workspace-5.5.0-2.fc23, polkit-kde-5.5.0-1.fc23, powerdevil-5.5.0-1.fc23, sddm-kcm-5.5.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.