Bug 1289792 - Docker image tags start with slash (/)
Docker image tags start with slash (/)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 19:23 EST by sedrubal
Modified: 2015-12-10 21:44 EST (History)
11 users (show)

See Also:
Fixed In Version: docker-1.9.1-4.git6ec29ef.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 20:50:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sedrubal 2015-12-08 19:23:57 EST
*Description of problem:

Docker always adds a `/``in front of the tag names (after adding new tags):

```
REPOSITORY                              TAG                 IMAGE ID            CREATED             VIRTUAL SIZE
/image                                  latest              38ffe511a292        8 minutes ago       271.5 MB
```

*Version-Release number of selected component (if applicable):

```
Client:
 Version:         1.9.1-fc23
 API version:     1.21
 Package version: docker-1.9.1-2.git78bc3ea.fc23.x86_64
 Go version:      go1.5.1
 Git commit:      f7c1d52-dirty
 Built:           Fri Nov 20 21:07:14 UTC 2015
 OS/Arch:         linux/amd64

Server:
 Version:         1.9.1-fc23
 API version:     1.21
 Package version: docker-1.9.1-2.git78bc3ea.fc23.x86_64
 Go version:      go1.5.1
 Git commit:      f7c1d52-dirty
 Built:           Fri Nov 20 21:07:14 UTC 2015
 OS/Arch:         linux/amd64
```

*How reproducible:

Every time


*Steps to Reproduce:

1. Run `docker build -t test .` with a Dockerfile like this: `FROM ubuntu:14.04`
2. Run `docker images`
3. Run `docker build -t foo .` with a Dockerfile like this: `FROM test`
4. Run `docker images`
5. Run `docker rmi /test`
6. Run `docker rmi test foo`

*Actual results:

1. works, but:
2. you can see `/test`
3. works, it takes `/test` or `test`
4. you can see `/test` and `/foo`
5. failes with message:
```
EOF
Error: failed to remove images: [/test]
```

6 . works and removes both images and neither `test` nor `/test` is visible...

*Expected results:

2. image should be named `test`
4. image should be named `foo`

*Additional info:


 I think since I have upgraded from `docker.x86_64 1:1.8.2-14.git8f9eabc.fc23` -> `docker.x86_64 1:1.9.1-2.git78bc3ea.fc23`

See https://github.com/docker/docker/issues/18406

*docker info:
```
Containers: 2
Images: 181
Server Version: 1.9.1-fc23
Storage Driver: devicemapper
 Pool Name: docker-253:2-5770-pool
 Pool Blocksize: 65.54 kB
 Base Device Size: 107.4 GB
 Backing Filesystem: 
 Data file: /dev/loop0
 Metadata file: /dev/loop1
 Data Space Used: 9.917 GB
 Data Space Total: 107.4 GB
 Data Space Available: 17.2 GB
 Metadata Space Used: 13.64 MB
 Metadata Space Total: 2.147 GB
 Metadata Space Available: 2.134 GB
 Udev Sync Supported: true
 Deferred Removal Enabled: false
 Deferred Deletion Enabled: false
 Deferred Deleted Device Count: 0
 Data loop file: /var/lib/docker/devicemapper/devicemapper/data
 Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
 Library Version: 1.02.109 (2015-09-22)
Execution Driver: native-0.2
Logging Driver: journald
Kernel Version: 4.2.6-301.fc23.x86_64
Operating System: Fedora 23 (Twenty Three)
CPUs: 4
Total Memory: 7.682 GiB
```
Comment 1 Fedora Update System 2015-12-09 04:31:46 EST
docker-1.9.1-4.git6ec29ef.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-5917f166c6
Comment 2 Fedora Update System 2015-12-09 23:55:42 EST
docker-1.9.1-4.git6ec29ef.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update docker'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-5917f166c6
Comment 3 Fedora Update System 2015-12-10 20:50:28 EST
docker-1.9.1-4.git6ec29ef.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 4 sedrubal 2015-12-10 21:44:49 EST
Yes it seems to be fixed im docker-1.9.1-4.git6ec29ef.fc23 . Thanks ;)

Note You need to log in before you can comment on or make changes to this bug.