Bug 1289834 - Fact required for IPv6 Compatibility For TripleO
Fact required for IPv6 Compatibility For TripleO
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: facter (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ga
: 8.0 (Liberty)
Assigned To: Mike Burns
: Triaged, ZStream
Depends On: 1283387
Blocks: 1280523
  Show dependency treegraph
 
Reported: 2015-12-09 00:38 EST by Gilles Dubreuil
Modified: 2015-12-17 20:56 EST (History)
13 users (show)

See Also:
Fixed In Version: facter-2.4.3-2.el7
Doc Type: Bug Fix
Doc Text:
Previously, facter did not fully provide facts for IPv6 addresses. As a result, the netmask6 and netmaks6_<interface> facts were missing. With this update, the 'netmask6' family of facts are added to Facter 2.x. This updates lib/facter/util/ip.rb, lib/facter/util/netmask.rb, and lib/facter/interfaces.rb files. As a result, facter returns netmask for default IPv6 address and IPv6 interfaces with an IPv6 address.
Story Points: ---
Clone Of: 1283387
Environment:
Last Closed: 2015-12-17 20:56:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (3.39 KB, patch)
2015-12-09 00:43 EST, Gilles Dubreuil
no flags Details | Diff

  None (edit)
Comment 2 Gilles Dubreuil 2015-12-09 00:43 EST
Created attachment 1103797 [details]
Patch

This clone of BZ#128338 is to track the patch on OSP8 where the clonee is targeting OSP7.

Using the same patch, it adds netmask6 and netmask6_<interface> facts for Facter 2 as a drop-in solution.
Comment 4 Gilles Dubreuil 2015-12-15 00:40:49 EST
This bug must be closed because:

1. Patching Facter 2.x is not always possible for channels like RDO (unless Facter package is added to it)

2. Avoiding patching downstream is preferable since the process is heavy.

Therefore another solution has been found, as part of the related BZ#1280523,
which provides the needed Facter facts as custom facts included into the involved module puppet-tripleo.

The downstream patch created so far for OSP8 is not needed and can be removed if already created.
Comment 5 Mike Burns 2015-12-15 07:30:57 EST
Jon, has this been shipped in a beta yet?  or is it a clean removal?
Comment 6 Jon Schlueter 2015-12-15 16:20:53 EST
facter-2.4.3-1.el7 was shipped with beta2 puddle

facter-2.4.3-2.el7 is in the latest puddle which is not shipped yet only with QE
Comment 7 Mike Burns 2015-12-15 16:39:18 EST
OK, lets drop it from the next puddle and then close WONTFIX this bug.

Note You need to log in before you can comment on or make changes to this bug.