Bug 1289845 - spurious failure of bug-1279376-rename-demoted-file.t
spurious failure of bug-1279376-rename-demoted-file.t
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nithya Balachandran
:
Depends On:
Blocks: 1291046
  Show dependency treegraph
 
Reported: 2015-12-09 01:59 EST by Raghavendra G
Modified: 2016-06-16 09:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1291046 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:49:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra G 2015-12-09 01:59:24 EST
Description of problem:

I am seeing regression failure [1]. The test which is failing is [2]. On my local machine the test always succeeds and even in the console output [1], the test has succeeded when run in debug mode for the second time. My changes are [3] which seems to be unrelated to [2].

[1] https://build.gluster.org/job/rackspace-regression-2GB-triggered/16575/consoleFull
[2] ./tests/bugs/tier/bug-1279376-rename-demoted-file.t
[3] review.gluster.org/12594

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-12-09 09:15:58 EST
REVIEW: http://review.gluster.org/12926 (tests/tier: spurious failure in rename test) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2015-12-09 21:02:23 EST
REVIEW: http://review.gluster.org/12926 (tests/tier: spurious failure in rename test) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 3 Vijay Bellur 2015-12-09 23:53:35 EST
REVIEW: http://review.gluster.org/12926 (tests/tier: spurious failure in rename test) posted (#3) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 4 Vijay Bellur 2015-12-10 09:43:22 EST
COMMIT: http://review.gluster.org/12926 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit aeaee78c4ec88f3c00efe22edc796102e03291da
Author: N Balachandran <nbalacha@redhat.com>
Date:   Wed Dec 9 19:36:42 2015 +0530

    tests/tier: spurious failure in rename test
    
    bug-1279376-rename-demoted-file.t fails sometimes
    The fix is based on the assumption that the test
    failed because the demotion happened too quickly.
    
    Change-Id: Ieccc736f387fcf6afaa72fa9918adb6dd34f2c8a
    BUG: 1289845
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12926
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 5 Raghavendra Talur 2016-03-08 15:21:44 EST
"tests" component is for tests framework only.
File a bug under test component if you find a bug in 
1. any of the *.rc files under tests/ 
2. run-tests.sh


For everything else, the bug should be filed on
1. component which is being tested by .t file if the .t file requires fix.
2. component which is causing a valid .t file to fail in regression.

I have used my best judgement here to move the bug to right component.
In case of ambiguity, I have placed the blame on the .t file component.

Please consider test bugs under the same backlog list that tracks other bugs in your component.
Comment 6 Niels de Vos 2016-06-16 09:49:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.