Bug 1289861 - [userinterface_public_566]The prompt info is confusing when all builds in the build chart are hidden
[userinterface_public_566]The prompt info is confusing when all builds in the...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Samuel Padgett
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 03:38 EST by Yanping Zhang
Modified: 2016-05-12 13:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:12:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanping Zhang 2015-12-09 03:38:58 EST
Description of problem:
When hide all builds in the build chart by clicking the small square status boxes under "Build Number" line, it shows info "No Completed Builds". It's confusing since we have builds with "Complete" status, users would misunderstand that there is no "Complete" status build. It's better to show info like "No Builds To Show".

Version-Release number of selected component (if applicable):
openshift v1.1-374-gddcd987
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

How reproducible:
Always

Steps to Reproduce:
1.Create app in project
2.Trigger several builds, make builds be finished with status Complete/Cancelled/Failed
3.Hide all builds in the build chart by clicking the small square status boxes under "Build Number" line. Check the prompt info.

Actual results:
3.It prompts "No Completes Builds".

Expected results:
3.It's better to show such info: "No Builds To Shows"

Additional info:
Comment 1 Samuel Padgett 2015-12-10 08:16:04 EST
Yangping, I disabled clicking the legend items in

https://github.com/openshift/origin/pull/6249

Do you think this is sufficient?
Comment 2 Yanping Zhang 2015-12-10 22:11:19 EST
Tested on latest origin code.
openshift v1.1-405-g4679093
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2
Since disabled clicking function on the items, now hovering on the items will show related builds, and gray other builds. It's acceptable, I think.
Move the bug to Verified.

Note You need to log in before you can comment on or make changes to this bug.