Bug 1289869 - Compile is broken in gluster master
Compile is broken in gluster master
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Manikandan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 03:59 EST by Michael Adam
Modified: 2016-09-20 00:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:49:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Adam 2015-12-09 03:59:24 EST
Description of problem:

Build is broken in current master:


  CC       glusterd_la-glusterd-handshake.lo
glusterd-utils.c: In function 'glusterd_volinfo_dup':
glusterd-utils.c:630:20: error: 'glusterd_volinfo_t {aka struct glusterd_volinfo_}' has no member named 'quota_version'
         new_volinfo->quota_version = volinfo->quota_version;
                    ^
glusterd-utils.c:630:45: error: 'glusterd_volinfo_t {aka struct glusterd_volinfo_}' has no member named 'quota_version'
         new_volinfo->quota_version = volinfo->quota_version;
                                             ^
Makefile:698: recipe for target 'glusterd_la-glusterd-utils.lo' failed


Version-Release number of selected component (if applicable):

Commit eb1a6e9f88cfd4c80c6af7260e5e6537cb76b6c0

How reproducible:

always

Steps to Reproduce:
1. compile the above hash

Actual results:

build fails

Expected results:

build succeeds

Additional info:
Comment 1 Vijay Bellur 2015-12-09 04:01:14 EST
REVIEW: http://review.gluster.org/12918 (glusterd: fix the build) posted (#1) for review on master by Michael Adam (obnox@samba.org)
Comment 2 Vijay Bellur 2015-12-09 06:25:19 EST
REVIEW: http://review.gluster.org/12922 (glusterd: fix the build) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2015-12-09 06:33:37 EST
COMMIT: http://review.gluster.org/12918 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 032e9a8bd923cf6913f0d3998546a2bd589adceb
Author: Michael Adam <obnox@samba.org>
Date:   Wed Dec 9 09:59:40 2015 +0100

    glusterd: fix the build
    
    Fix the build broken in 6e9f88cfd4c80c6af7260e5e6537cb76b6c0
    
    Change-Id: I0c5cedff980688cb47f3f0e9f4968c23d2f507d3
    BUG: 1289869
    Signed-off-by: Michael Adam <obnox@samba.org>
    Reviewed-on: http://review.gluster.org/12918
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
Comment 4 Mike McCune 2016-03-28 19:44:20 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Niels de Vos 2016-06-16 09:49:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.