Bug 1289902 - Fedora Atomic does not persist journal across reboot
Fedora Atomic does not persist journal across reboot
Status: CLOSED DUPLICATE of bug 1265295
Product: Fedora
Classification: Fedora
Component: atomic (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 05:17 EST by Stef Walter
Modified: 2015-12-10 08:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 08:11:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2015-12-09 05:17:54 EST
Description of problem:

Fedora Atomic (unlike Fedora) does not persist its journal across reboots. This means that all the new work centering around the journal (such as the docker's journal driver, and cockpit's journal inspector) are far less useful on Fedora Atomic.

Version-Release number of selected component (if applicable):

* 2015-12-08 21:17:20     22.185             82212b2ac6     fedora-atomic     fedora-atomic:fedora-atomic/f22/x86_64/docker-host     


How reproducible:

Every time

Steps to Reproduce:
$ logger 'BEFORE BOOT'
$ sudo reboot
$ journalctl | grep 'BEFORE BOOT'

Actual results:

Journal is thrown away.

Expected results:

Journal kept past reboot
Comment 1 Stef Walter 2015-12-09 05:18:17 EST
This bug was caught by the Cockpit integration tests.
Comment 2 Dusty Mabe 2015-12-09 08:55:38 EST
I reported this a while back. Would still like for it to be fixed:

https://bugzilla.redhat.com/show_bug.cgi?id=1265295
Comment 3 Dusty Mabe 2015-12-09 10:36:25 EST
Stef, can you confirm it is the same bug? After the 2nd reboot is the journal persisted to disk?

Colin, what component should this bug be under? I opened 1265295 against rpm-ostree.
Comment 4 Stef Walter 2015-12-10 08:11:25 EST
(In reply to Dusty Mabe from comment #2)
> I reported this a while back. Would still like for it to be fixed:

OSTree instances are brought up (eg: in the cloud) and not necessarily rebooted before use would be affected by this. So it's not a corner case.

(In reply to Dusty Mabe from comment #3)
> Stef, can you confirm it is the same bug? After the 2nd reboot is the
> journal persisted to disk?

It is the same bug. Will mark this as a duplicate.

*** This bug has been marked as a duplicate of bug 1265295 ***

Note You need to log in before you can comment on or make changes to this bug.