Bug 1289922 - Implement SIMD support on EC
Implement SIMD support on EC
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Xavier Hernandez
: Triaged
Depends On:
Blocks: 1374841
  Show dependency treegraph
 
Reported: 2015-12-09 06:03 EST by Xavier Hernandez
Modified: 2017-03-06 12:20 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.10.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1374841 (view as bug list)
Environment:
Last Closed: 2017-03-06 12:20:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Hernandez 2015-12-09 06:03:20 EST
Description of problem:

Make use of hardware SIMD support to speed up EC's computations.

Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-07-25 07:21:19 EDT
REVIEW: http://review.gluster.org/12837 (cluster/ec: Add support for hardware acceleration) posted (#6) for review on master by Xavier Hernandez (xhernandez@datalab.es)
Comment 2 Worker Ant 2016-09-01 16:45:56 EDT
REVIEW: http://review.gluster.org/12837 (cluster/ec: Add support for hardware acceleration) posted (#7) for review on master by Xavier Hernandez (xhernandez@datalab.es)
Comment 3 Worker Ant 2016-09-01 19:30:29 EDT
REVIEW: http://review.gluster.org/12837 (cluster/ec: Add support for hardware acceleration) posted (#8) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Worker Ant 2016-09-06 14:28:47 EDT
REVIEW: http://review.gluster.org/12837 (cluster/ec: Add support for hardware acceleration) posted (#9) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Worker Ant 2016-09-08 02:44:00 EDT
REVIEW: http://review.gluster.org/12837 (cluster/ec: Add support for hardware acceleration) posted (#10) for review on master by Xavier Hernandez (xhernandez@datalab.es)
Comment 6 Worker Ant 2016-09-08 13:08:29 EDT
COMMIT: http://review.gluster.org/12837 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 593b7a83f7408e59ab7b3ef7dfc4fe4096d6e3cd
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Tue Dec 1 11:50:54 2015 +0100

    cluster/ec: Add support for hardware acceleration
    
    This patch implements functionalities for fast encoding/decoding
    using hardware support. Currently optimized x86_64, SSE and AVX is
    added.
    
    Additionally this patch implements a caching mecanism for inverse
    matrices to reduce computation time, as well as a new method for
    computing the inverse that takes quadratic time instead of cubic.
    
    Finally some unnecessary memory copies have been eliminated to
    further increase performance.
    
    Change-Id: I26c75f26fb4201bd22b51335448ea4357235065a
    BUG: 1289922
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/12837
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 7 Shyamsundar 2017-03-06 12:20:01 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.