Bug 1289938 - nettle-devel.i686 conflicts with nettle-devel.x86_64
nettle-devel.i686 conflicts with nettle-devel.x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nettle (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 06:49 EST by Kenneth Soerensen
Modified: 2015-12-12 23:21 EST (History)
5 users (show)

See Also:
Fixed In Version: nettle-3.1.1-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-12 23:21:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenneth Soerensen 2015-12-09 06:49:14 EST
Description of problem:
nettle-devel.i686 conflicts with nettle-devel.x86_64 because the file /usr/include/nettle/version.h conflicts. The problem seems to be caused by the macro GMP_NUMB_BITS in version.h, which is defined to either 32 or 64.


Version-Release number of selected component (if applicable):
nettle-devel-3.1.1-5.fc23 and earlier


How reproducible:
always


Steps to Reproduce:
1.dnf install nettle-devel.x86_64 nettle-devel.i686


Actual results:
Error: Transaction check error:
  file /usr/include/nettle/version.h from install of nettle-devel-3.1.1-5.fc23.i686 conflicts with file from package nettle-devel-3.1.1-5.fc23.x86_64


Expected results:
nettle-devel installed

Additional info:
Comment 1 Nikos Mavrogiannopoulos 2015-12-09 07:06:56 EST
We can simply delete this macro in fedora as we don't use MINI_GMP.
Comment 2 Fedora Update System 2015-12-09 09:21:06 EST
nettle-3.1.1-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-32b686018d
Comment 3 Fedora Update System 2015-12-09 23:54:50 EST
nettle-3.1.1-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update nettle'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-32b686018d
Comment 4 Kenneth Soerensen 2015-12-10 07:50:23 EST
nettle-3.1.1-6 is working.

Thanks for the quick response.
Comment 5 Fedora Update System 2015-12-12 23:21:54 EST
nettle-3.1.1-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.