Bug 1289939 - Preupgrade-assistant package should be NOARCH
Preupgrade-assistant package should be NOARCH
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Hracek
Tereza Cerna
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 06:49 EST by Petr Hracek
Modified: 2016-05-11 04:26 EDT (History)
7 users (show)

See Also:
Fixed In Version: preupgrade-assistant-2.1.3-1.el6
Doc Type: Bug Fix
Doc Text:
The preupgrade-assistant tool is now .noarch Previously, preupgrade-assistant was distributed as set of architecture-specific RPM packages. As this is no longer required, it will be distributed as single cross-architecture (noarch) package.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-11 04:26:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Hracek 2015-12-09 06:49:43 EST
Description of problem:
Nowadays preupgrade-assistant has ARCH builds.
Because of preupgrade assistant has only python scripts I suggest to switch it to NOARCH builds.

There is no reason to have ARCH builds.
Comment 4 Alois Mahdal 2016-02-08 09:01:31 EST
(In reply to Alois Mahdal from comment #1)
[...]
> One way is look at TPS tab as see if the tests have been scheduled at
> expected arch/variant combinations (same as ER#21377, ie. ppc64m, s390x,
> x86_64 but *not* i386).

this can be done more easily by using `rqkit-anydiff`, new tool announced on qe-baseos-demons mtg and list:

    rqkit anydiff er/tps 21377 22151

or

    rqkit anydiff -r 3 er/tps 21377 22151

to hide gory details such as times and hostnames.

(still has same disadvantages as mentioned, but it's better than just looking at HTML)
Comment 5 Tereza Cerna 2016-03-31 09:19:26 EDT
Verified. Packages are noarch. Builds, spec file, rpmdiff and rqkit was checked and everything is OK.

Verified in:
preupgrade-assistant-2.1.5-4.el6
Comment 7 errata-xmlrpc 2016-05-11 04:26:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1022.html

Note You need to log in before you can comment on or make changes to this bug.