Bug 1289940 - [libosmocore] Fix test on big-endian machines
[libosmocore] Fix test on big-endian machines
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libosmocore (Show other bugs)
rawhide
ppc64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: PPCTracker
  Show dependency treegraph
 
Reported: 2015-12-09 06:50 EST by Rafael Fonseca
Modified: 2016-01-04 18:27 EST (History)
1 user (show)

See Also:
Fixed In Version: libosmocore-0.9.0-3.20151109git916423ef.fc23 libosmocore-0.9.0-3.20151109git916423ef.fc22 libosmocore-0.9.0-3.20151109git916423ef.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 13:52:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix test on big-endian (2.38 KB, patch)
2015-12-09 06:50 EST, Rafael Fonseca
no flags Details | Diff
Upstream proposed fix (1.64 KB, patch)
2015-12-09 14:10 EST, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Rafael Fonseca 2015-12-09 06:50:13 EST
Created attachment 1103842 [details]
Fix test on big-endian

Description of problem: test fails on big-endian machines because of the way bit-fields are allocated in these architectures.


Version-Release number of selected component (if applicable): 0.9.0-2


How reproducible: always on koji-ppc.


Additional info: Patch attached.
Comment 1 Jaroslav Škarvada 2015-12-09 07:09:29 EST
I am afraid this is not the correct fix. The correct way is to fix the library, not patching the test to only hide the problem. The issue is currently discussed upstream.
Comment 2 Jaroslav Škarvada 2015-12-09 14:10 EST
Created attachment 1104088 [details]
Upstream proposed fix

I am afraid that using bitfields is not portable. I think that macros and bitmasks should be used. I pointed this upstream, but I am using the fix for now.
Comment 3 Fedora Update System 2015-12-09 14:36:45 EST
libosmocore-0.9.0-3.20151109git916423ef.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1619da728a
Comment 4 Fedora Update System 2015-12-09 14:37:18 EST
libosmocore-0.9.0-3.20151109git916423ef.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f2da169de3
Comment 5 Fedora Update System 2015-12-09 14:51:09 EST
libosmocore-0.9.0-3.20151109git916423ef.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-da529ef26f
Comment 6 Fedora Update System 2015-12-10 06:21:43 EST
libosmocore-0.9.0-3.20151109git916423ef.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update libosmocore'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-da529ef26f
Comment 7 Fedora Update System 2015-12-11 01:02:25 EST
libosmocore-0.9.0-3.20151109git916423ef.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update libosmocore'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1619da728a
Comment 8 Fedora Update System 2015-12-11 14:58:12 EST
libosmocore-0.9.0-3.20151109git916423ef.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update libosmocore'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f2da169de3
Comment 9 Fedora Update System 2016-01-04 13:52:03 EST
libosmocore-0.9.0-3.20151109git916423ef.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2016-01-04 14:56:57 EST
libosmocore-0.9.0-3.20151109git916423ef.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-01-04 18:27:32 EST
libosmocore-0.9.0-3.20151109git916423ef.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.