Bug 1289967 - Fade "Numa Pinning" button, in case if VM pinned to host that does not have "NUMA Support"
Fade "Numa Pinning" button, in case if VM pinned to host that does not have "...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.3
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-3.6.3
: 3.6.3.3
Assigned To: Roman Mohr
Artyom
: Reopened, Triaged
Depends On: 1265953
Blocks: 1279178
  Show dependency treegraph
 
Reported: 2015-12-09 07:35 EST by Artyom
Modified: 2016-03-11 02:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: As long as the alphabetically first host had numa support, the "Numa Pinning" pinning button was not greyed out. Consequence: It was possible to do numa pinning on hosts with just one numa node (which is the equivalent of no numa architecture) but saving the pinning failed because of correct backend validations. Backend validation was fixed in https://bugzilla.redhat.com/show_bug.cgi?id=1279178 Fix: Correctly detect in the UI if the currently selected host supports NUMA. Result: Greys out all numa related boxes and buttons in the UI when a host without numa support is selected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 02:24:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ykaul: exception+
mgoldboi: planning_ack+
rmohr: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
screenshot (71.77 KB, image/png)
2015-12-09 07:35 EST, Artyom
no flags Details
screenshots (182.94 KB, application/zip)
2016-02-21 07:56 EST, Artyom
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51380 master MERGED webadmin: Fix check if selected dedicated host supports NUMA 2016-01-12 08:45 EST
oVirt gerrit 51640 ovirt-engine-3.6 MERGED webadmin: Fix check if selected dedicated host supports NUMA 2016-01-14 09:18 EST
oVirt gerrit 53364 None None None 2016-02-22 04:52 EST
oVirt gerrit 53784 ovirt-engine-3.6 MERGED webadmin: Make multiselect behaviour of list model consistent 2016-02-23 02:43 EST
oVirt gerrit 53786 ovirt-engine-3.6.3 MERGED webadmin: Make multiselect behaviour of list model consistent 2016-02-23 02:44 EST

  None (edit)
Description Artyom 2015-12-09 07:35:03 EST
Created attachment 1103871 [details]
screenshot

Description of problem:
I have possibility to pin VNUMA node to PNUMA node also in case when host have one NUMA node(in our terms not support NUMA).

Version-Release number of selected component (if applicable):
rhevm-3.6.1.1-0.1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create vm with one or more NUMA nodes and pin it to host without NUMA Support
2. 
3.

Actual results:
Possible to pin VNUMA node to PNUMA node(via "Numa Pinning" button)

Expected results:
"Numa Pinning" button must be faded in case if vm pinned to host without "NUMA Support"

Additional info:
I believe we also need to add validation for REST api
Comment 1 Red Hat Bugzilla Rules Engine 2016-01-14 09:21:30 EST
Fixed bug tickets must have target milestone set prior to fixing them. Please set the correct milestone and move the bugs back to the previous status after this is corrected.
Comment 2 Gil Klein 2016-02-17 02:54:43 EST
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA
Comment 3 Artyom 2016-02-21 07:56 EST
Created attachment 1129005 [details]
screenshots

Checked on rhevm-backend-3.6.3.2-0.1.el6.noarch
Looks like now it works randomly, sometime it fade NUMA parameters for host with NUMA architecture, sometimes leave open NUMA parameters for host without NUMA architecture.
Also it fade all NUMA parameters and not only "NUMA pinning" button.

host with NUMA architecture
============================
alma05.qa.lab.tlv.redhat.com
alma06.qa.lab.tlv.redhat.com

host without NUMA architecture
============================
cyan-vdsg.qa.lab.tlv.redhat.com

See screenshots for more information
Comment 4 Red Hat Bugzilla Rules Engine 2016-02-21 07:57:07 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Roman Mohr 2016-02-22 04:38:29 EST
(In reply to Artyom from comment #3)
> Created attachment 1129005 [details]
> screenshots
> 
> Checked on rhevm-backend-3.6.3.2-0.1.el6.noarch
> Looks like now it works randomly, sometime it fade NUMA parameters for host
> with NUMA architecture, sometimes leave open NUMA parameters for host
> without NUMA architecture.
> Also it fade all NUMA parameters and not only "NUMA pinning" button.
> 
> host with NUMA architecture
> ============================
> alma05.qa.lab.tlv.redhat.com
> alma06.qa.lab.tlv.redhat.com
> 
> host without NUMA architecture
> ============================
> cyan-vdsg.qa.lab.tlv.redhat.com
> 
> See screenshots for more information

The patch in Bug 1265953 solves this problem. You can work around it by selecting the preferred host, click on 'Any Host' and then select 'Specific' again.
Comment 6 Roman Mohr 2016-02-22 04:52:07 EST
This is a very annoying error with a very isolated and simple fix (https://gerrit.ovirt.org/#/c/53364/2). The select box modified there is only used at this one place in the UI.
Comment 7 Artyom 2016-02-26 07:51:05 EST
Verified on rhevm-webadmin-portal-3.6.3.3-0.1.el6.noarch

1) add three hosts two with NUMA support and one without
2) change vm migration policy to "Not allow migration"
3) check numa parameters when check different specific host
NUMA parameters close for non-NUMA host and opened for NUMA host

Note You need to log in before you can comment on or make changes to this bug.