Bug 1289969 - Add 'admin' key to [ovirt] .vv file section
Add 'admin' key to [ovirt] .vv file section
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1210248
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 07:43 EST by Fabiano Fidêncio
Modified: 2016-05-10 17:19 EDT (History)
10 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-8.el6
Doc Type: Bug Fix
Doc Text:
No doc needed
Story Points: ---
Clone Of: 1210248
Environment:
Last Closed: 2016-05-10 17:19:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 xiaodwan 2015-12-22 06:16:37 EST
I verified below 3 senarioes with latest package and the "admin" key works well.
# rpm -q virt-viewer libgovirt
virt-viewer-2.0-9.el6.x86_64
libgovirt-0.3.2-2.el6.x86_64


1. If a VM can be seen by a given user both in admin portal and in user portal, then admin=0/1 should not make a difference.
2. If a VM cannot be seen by the user in the user portal and they can log in as an admin, then admin=1 should work, and admin=0 should fail.
3. If the user cannot login as an admin, and they can see the VM in the user portal, then admin=1 should fail, and admin=0 should work.

For details steps, you can refer this case:
https://polarion.engineering.redhat.com/polarion/#/project/RHEL6/workitem?id=RHEL6-8372

So move it from ON_QA to VERIFIED.
Comment 4 errata-xmlrpc 2016-05-10 17:19:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0832.html

Note You need to log in before you can comment on or make changes to this bug.