Bug 1289971 - virt-viewer cannot reconnect libvirtd connection via ssh after libvirtd restart
virt-viewer cannot reconnect libvirtd connection via ssh after libvirtd restart
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.8
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1164052 1243228 1246395
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 07:47 EST by Fabiano Fidêncio
Modified: 2016-05-10 17:19 EDT (History)
13 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-8.el6
Doc Type: Bug Fix
Doc Text:
Cause: Notifications about libvirt going away were not received when connecting to a VM hosted in a RHEL-7 (or newer). Consequence: virt-viewer was not able to reconnect to libvirtd after it goes away. Fix: Set keepAlive on the libvirt connection. Result: virt-viewer is able to reconnect to libvirtd after it does away.
Story Points: ---
Clone Of: 1164052
Environment:
Last Closed: 2016-05-10 17:19:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 mxie@redhat.com 2015-12-17 04:02:17 EST
According the comment: one important info that has been missing about how to reproduce this bug is that the remote host *MUST* be a RHEL-7 or newer.Older versions of libvirt (in the remote host) don't present the keepalive problem,

I can reproduce the bug on below build with a RHEL7 remote host
virt-viewer-2.0-7.el6.x86_64

Try to verify this bug with build:
virt-viewer-2.0-8.el6.x86_64


Steps to Reproduce:
1. install a spice guest on a rhel7 remote host and shut it down
2. use virt-viewer to connect the guest on rhel6 host with --wait
#virt-viewer -c qemu+ssh://remote_rhel7_ip/system vm --wait --debug --spice-debug
3. restart libvirtd on rhel7 remote host
# service libvirtd restart


Results now:

Step 3:there is more debug message pop out on after libvirtd restart, 

#virt-viewer -c qemu+ssh://remote_rhel7_ip/system vm --wait --debug --spice-debug
(virt-viewer:23384): virt-viewer-DEBUG: Connect timer fired
(virt-viewer:23384): virt-viewer-DEBUG: initial connect
(virt-viewer:23384): virt-viewer-DEBUG: notebook show status 0x1adf000
(virt-viewer:23384): virt-viewer-DEBUG: Update timeout 0x1b4fe40 10 4000
(virt-viewer:23384): virt-viewer-DEBUG: Update timeout 0x1b4fe40 10 4000
(virt-viewer:23384): virt-viewer-DEBUG: Update timeout 0x1b4fe40 10 5000
(virt-viewer:23384): virt-viewer-DEBUG: virt_viewer_app_set_uuid_string: UUID changed to 9d86c356-c434-4209-81d2-2f38533a2eb7
(virt-viewer:23384): virt-viewer-DEBUG: No guest-specific fullscreen config, using fallback
(virt-viewer:23384): virt-viewer-DEBUG: notebook show status 0x1adf000
(virt-viewer:23384): virt-viewer-DEBUG: Update timeout 0x1b4fe40 10 5000
(virt-viewer:23384): virt-viewer-DEBUG: Update timeout 0x1b4fe40 10 5000
(virt-viewer:23384): virt-viewer-DEBUG: Update timeout 0x1b4fe40 10 5000
(virt-viewer:23384): virt-viewer-DEBUG: notebook show status 0x1adf000
(virt-viewer:23384): virt-viewer-DEBUG: Guest test has not activated its display yet, waiting for it to start

So move this bug from ON_QA to VERIFIED.
Comment 5 errata-xmlrpc 2016-05-10 17:19:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0832.html

Note You need to log in before you can comment on or make changes to this bug.