Bug 1289984 - Cannot clone from github.com using http/https
Cannot clone from github.com using http/https
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: git (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: pstodulk
Andrej Dzilský
: Patch
Depends On:
Blocks: 1355829 1359264
  Show dependency treegraph
 
Reported: 2015-12-09 08:11 EST by Andrei Stepanov
Modified: 2017-03-21 06:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: git-1.7.1-7.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 06:01:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (2.73 KB, patch)
2015-12-11 04:11 EST, pstodulk
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0640 normal SHIPPED_LIVE git bug fix update 2017-03-21 08:31:15 EDT

  None (edit)
Description Andrei Stepanov 2015-12-09 08:11:04 EST
git clone hangups during cloning from github.com

git-1.7.1-3.el6_4.1.x86_64
curl-7.19.7-46.el6.x86_64

How reproducible: always

# GIT_CURL_VERBOSE=1 GIT_TRACE=1 git clone --verbose http://github.com/autotest/tp-libvirt.git
trace: built-in: git 'clone' '--verbose' 'http://github.com/autotest/tp-libvirt.git'
Initialized empty Git repository in /root/tp-libvirt/.git/
trace: run_command: 'git-remote-http' 'http://github.com/autotest/tp-libvirt.git' 'http://github.com/autotest/tp-libvirt.git'
* Couldn't find host github.com in the .netrc file; using defaults
* About to connect() to github.com port 80 (#0)
*   Trying 192.30.252.129... * Connected to github.com (192.30.252.129) port 80 (#0)
> GET /autotest/tp-libvirt.git/info/refs?service=git-upload-pack HTTP/1.1
User-Agent: git/1.7.1
Host: github.com
Accept: */*
Pragma: no-cache

< HTTP/1.1 301 Moved Permanently
< Content-length: 0
< Location: https://github.com/autotest/tp-libvirt.git/info/refs?service=git-upload-pack
< Connection: close
< 
* Closing connection #0
* Issue another request to this URL: 'https://github.com/autotest/tp-libvirt.git/info/refs?service=git-upload-pack'
* Couldn't find host github.com in the .netrc file; using defaults
* About to connect() to github.com port 443 (#0)
*   Trying 192.30.252.129... * Connected to github.com (192.30.252.129) port 443 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* SSL connection using TLS_RSA_WITH_AES_128_CBC_SHA
* Server certificate:
* 	subject: CN=github.com,O="GitHub, Inc.",L=San Francisco,ST=California,C=US,postalCode=94107,STREET=548 4th Street,serialNumber=5157550,incorporationState=Delaware,incorporationCountry=US,businessCategory=Private Organization
* 	start date: Apr 08 00:00:00 2014 GMT
* 	expire date: Apr 12 12:00:00 2016 GMT
* 	common name: github.com
* 	issuer: CN=DigiCert SHA2 Extended Validation Server CA,OU=www.digicert.com,O=DigiCert Inc,C=US
> GET /autotest/tp-libvirt.git/info/refs?service=git-upload-pack HTTP/1.1
User-Agent: git/1.7.1
Host: github.com
Accept: */*
Pragma: no-cache

< HTTP/1.1 200 OK
< Server: GitHub Babel 2.0
< Content-Type: application/x-git-upload-pack-advertisement
< Transfer-Encoding: chunked
< Expires: Fri, 01 Jan 1980 00:00:00 GMT
< Pragma: no-cache
< Cache-Control: no-cache, max-age=0, must-revalidate
< Vary: Accept-Encoding
< X-GitHub-Request-Id: D5AF250A:6925:391B1B8:566827FE
< 
* Expire cleared
* Connection #0 to host github.com left intact
trace: run_command: 'fetch-pack' '--stateless-rpc' '--lock-pack' '--thin' 'http://github.com/autotest/tp-libvirt.git' 'refs/heads/master'
trace: exec: 'git' 'fetch-pack' '--stateless-rpc' '--lock-pack' '--thin' 'http://github.com/autotest/tp-libvirt.git' 'refs/heads/master'
trace: built-in: git 'fetch-pack' '--stateless-rpc' '--lock-pack' '--thin' 'http://github.com/autotest/tp-libvirt.git' 'refs/heads/master'
* Couldn't find host github.com in the .netrc file; using defaults
* About to connect() to github.com port 80 (#0)
*   Trying 192.30.252.129... * connected
* Connected to github.com (192.30.252.129) port 80 (#0)
> POST /autotest/tp-libvirt.git/git-upload-pack HTTP/1.1
User-Agent: git/1.7.1
Host: github.com
Accept-Encoding: deflate, gzip
Content-Type: application/x-git-upload-pack-request
Accept: application/x-git-upload-pack-result
Content-Length: 116

< HTTP/1.1 301 Moved Permanently
< Content-length: 0
< Location: https://github.com/autotest/tp-libvirt.git/git-upload-pack
< Connection: close
< 
* Closing connection #0
* Issue another request to this URL: 'https://github.com/autotest/tp-libvirt.git/git-upload-pack'
* Violate RFC 2616/10.3.2 and switch from POST to GET
* Couldn't find host github.com in the .netrc file; using defaults
* About to connect() to github.com port 443 (#0)
*   Trying 192.30.252.129... * connected
* Connected to github.com (192.30.252.129) port 443 (#0)
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* SSL connection using TLS_RSA_WITH_AES_128_CBC_SHA
* Server certificate:
* 	subject: CN=github.com,O="GitHub, Inc.",L=San Francisco,ST=California,C=US,postalCode=94107,STREET=548 4th Street,serialNumber=5157550,incorporationState=Delaware,incorporationCountry=US,businessCategory=Private Organization
* 	start date: Apr 08 00:00:00 2014 GMT
* 	expire date: Apr 12 12:00:00 2016 GMT
* 	common name: github.com
* 	issuer: CN=DigiCert SHA2 Extended Validation Server CA,OU=www.digicert.com,O=DigiCert Inc,C=US
> GET /autotest/tp-libvirt.git/git-upload-pack HTTP/1.1
User-Agent: git/1.7.1
Host: github.com
Accept-Encoding: deflate, gzip
Content-Type: application/x-git-upload-pack-request
Accept: application/x-git-upload-pack-result

< HTTP/1.1 200 OK
< Server: GitHub Babel 2.0
< Content-Type: application/x-git-upload-pack-result
< Transfer-Encoding: chunked
< Expires: Fri, 01 Jan 1980 00:00:00 GMT
< Pragma: no-cache
< Cache-Control: no-cache, max-age=0, must-revalidate
< Vary: Accept-Encoding
< X-GitHub-Request-Id: D5AF250A:6921:2438095:566827FF
< 
* Connection #0 to host github.com left intact

After the last line git stays silent.
Comment 2 pstodulk 2015-12-11 04:11 EST
Created attachment 1104595 [details]
Patch
Comment 8 errata-xmlrpc 2017-03-21 06:01:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0640.html

Note You need to log in before you can comment on or make changes to this bug.