Bug 1290002 - appliance_console fails to start if no IP assigned
appliance_console fails to start if no IP assigned
Status: CLOSED DUPLICATE of bug 1286560
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.6.0
Assigned To: Nick Carboni
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 08:31 EST by Christian Jung
Modified: 2015-12-15 09:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 09:10:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot with error message (14.91 KB, image/png)
2015-12-09 08:31 EST, Christian Jung
no flags Details
output of ip addr show eth0 (36.51 KB, image/png)
2015-12-15 08:47 EST, Christian Jung
no flags Details

  None (edit)
Description Christian Jung 2015-12-09 08:31:42 EST
Created attachment 1103899 [details]
screenshot with error message

Description of problem:
If you try to start appliance_console but the appliance does not have an IP address configured, it will fail to start.

Version-Release number of selected component (if applicable):
5.5.0.13

How reproducible:
always

Steps to Reproduce:
1. deploy a CF appliance but make sure there is no DHCP available
2. log in and start appliance_console
3.

Actual results:
appliance_console fails

Expected results:


Additional info:
I only tested this with CF4 on RHEV, but I expect similar results with other providers.
Comment 2 Nick Carboni 2015-12-10 10:54:59 EST
Christian,

Can you provide the output from `ip addr show eth0` when this fails for you?
This may have been fixed already and I can't seem to reproduce it.

Thanks

For me the output shows:

2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:0c:29:e0:d6:51 brd ff:ff:ff:ff:ff:ff
Comment 3 Nick Carboni 2015-12-10 11:01:05 EST
With a slightly different configuration I get:

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:0c:29:e0:d6:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::20c:29ff:fee0:d651/64 scope link 
       valid_lft forever preferred_lft forever

In this case it is the same failure as https://bugzilla.redhat.com/show_bug.cgi?id=1286560 and has been fixed.
Comment 4 Nick Carboni 2015-12-15 08:26:50 EST
Any update here? Otherwise I will close as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1286560 as they have the same symptoms and fix.
Comment 5 Christian Jung 2015-12-15 08:47 EST
Created attachment 1106036 [details]
output of ip addr show eth0
Comment 6 Nick Carboni 2015-12-15 09:10:00 EST
Thanks, closing as a duplicate.

*** This bug has been marked as a duplicate of bug 1286560 ***

Note You need to log in before you can comment on or make changes to this bug.