Bug 1290011 - "Bluetooth: hci0: turning off Intel device LED failed (-19)" observed after I turn of bluetooth
"Bluetooth: hci0: turning off Intel device LED failed (-19)" observed after I...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 08:45 EST by Zhang Yi
Modified: 2017-03-14 09:02 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-10 10:37:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhang Yi 2015-12-09 08:45:14 EST
Description of problem:
"Bluetooth: hci0: turning off Intel device LED failed (-19)" observed after I turn of bluetooth

Version-Release number of selected component (if applicable):
4.2.6-301.fc23.x86_64 on W541 laptop

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
[  627.045233] Bluetooth: hci0 sending frame failed (-19)
[  627.045390] Bluetooth: hci0: turning off Intel device LED failed (-19)
[  694.112153] usb 1-11: new full-speed USB device number 7 using xhci_hcd
[  694.277655] usb 1-11: New USB device found, idVendor=8087, idProduct=07dc
[  694.277658] usb 1-11: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[  694.291929] Bluetooth: hci0: read Intel version: 3707100180012d0d00
[  694.293727] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.80.1.2d.d.bseq
[  694.468241] Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated
[  716.015425] usb 1-11: USB disconnect, device number 7
[  716.015585] Bluetooth: hci0: turning off Intel device LED failed (-19)
[  731.657107] usb 1-11: new full-speed USB device number 8 using xhci_hcd
[  731.822582] usb 1-11: New USB device found, idVendor=8087, idProduct=07dc
[  731.822586] usb 1-11: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[  731.836848] Bluetooth: hci0: read Intel version: 3707100180012d0d00
[  731.836873] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.80.1.2d.d.bseq
[  732.010075] Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated
[  741.295126] usb 1-11: USB disconnect, device number 8
[  741.295303] Bluetooth: hci0 sending frame failed (-19)
[  741.295349] Bluetooth: hci0: turning off Intel device LED failed (-19)
Comment 1 Laura Abbott 2016-09-23 15:48:10 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 2 Zhang Yi 2016-10-08 02:33:57 EDT
Hello Laura
My W541 laptop was returned before, so I cannot retest it now, sorry for the inconvenience.

Thanks
Yi
Comment 3 Laura Abbott 2016-10-10 10:37:21 EDT
Thanks for letting us know
Comment 4 Steven Ding 2017-03-14 09:02:20 EDT
Hello, Laura, 

This is Steven Ding. I'm a Debian user, but I have the same issue with Lenovo W540. 

It fails when peering with an BT speaker. 
I'm using the latest 4.4 kernel version: 4.4.52. 

Additional information:

$ uname -a
Linux W540 4.4.52-2017031402 #3 SMP Tue Mar 14 19:27:54 CST 2017 x86_64 GNU/Linux

$ dmesg | grep -i bluetooth
[    2.397663] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
[    4.185803] Bluetooth: Core ver 2.21
[    4.185817] Bluetooth: HCI device and connection manager initialized
[    4.185820] Bluetooth: HCI socket layer initialized
[    4.185822] Bluetooth: L2CAP socket layer initialized
[    4.185827] Bluetooth: SCO socket layer initialized
[  248.780132] Bluetooth: hci0: read Intel version: 370710018002030d00
[  248.780630] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.80.2.3.d.bseq
[  248.994220] Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated
[  249.113491] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  249.113495] Bluetooth: BNEP filters: protocol multicast
[  249.113499] Bluetooth: BNEP socket layer initialized
[  287.077582] Bluetooth: hci0 sending frame failed (-19)
[  287.077662] Bluetooth: hci0: turning off Intel device LED failed (-19)
[  983.170460] Bluetooth: hci0: read Intel version: 370710018002030d00
[  983.170484] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.80.2.3.d.bseq
[  983.386445] Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated
[  994.243998] Bluetooth: hci0 sending frame failed (-19)
[  994.244094] Bluetooth: hci0: turning off Intel device LED failed (-19)

Note You need to log in before you can comment on or make changes to this bug.