This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1290018 - Unable to install vdsm on RHEL6
Unable to install vdsm on RHEL6
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: vdsm (Show other bugs)
3.1
x86_64 Linux
high Severity high
: ---
: RHGS 3.1.2
Assigned To: Ramesh N
Triveni Rao
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 09:08 EST by Triveni Rao
Modified: 2016-05-16 00:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: vdsm-4.16.30-1.2.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:12:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Triveni Rao 2015-12-09 09:08:00 EST
Description of problem:
i am trying to install vdsm on RHEL6.7 RHGS but i am facing issues with the vdsm.

Version-Release number of selected component (if applicable):


How reproducible:
easily

Steps to Reproduce:
1.install RHGS 312 based rhel6.7
2. add latest repo 
3. yum update 

Actual results:
---> Package vdsm-python.noarch 0:4.16.30-1.1.el6rhs will be an update
---> Package vdsm-python-zombiereaper.noarch 0:4.16.20-1.3.el6rhs will be updated
---> Package vdsm-python-zombiereaper.noarch 0:4.16.30-1.1.el6rhs will be an update
---> Package vdsm-reg.noarch 0:4.16.20-1.3.el6rhs will be updated
---> Package vdsm-reg.noarch 0:4.16.30-1.1.el6rhs will be an update
---> Package vdsm-xmlrpc.noarch 0:4.16.20-1.3.el6rhs will be updated
---> Package vdsm-xmlrpc.noarch 0:4.16.30-1.1.el6rhs will be an update
---> Package vdsm-yajsonrpc.noarch 0:4.16.20-1.3.el6rhs will be updated
---> Package vdsm-yajsonrpc.noarch 0:4.16.30-1.1.el6rhs will be an update
--> Finished Dependency Resolution
Error: Package: vdsm-4.16.30-1.1.el6rhs.x86_64 (download.eng.bos.redhat.com_rel-eng_RHGS_3.1-u2-RHEL-6_2015-12-08.1_RH-Gluster-3-Server_x86_64_os_)
           Requires: libvirt-daemon
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@casino-vm6 ~]# 


Expected results:
Installation should be smooth

Additional info:
Comment 3 Sreenath G 2015-12-09 09:24:31 EST
Hi,

   The libvirt-daemon sub-pkg (rpm) doesn't even exist for el6 is what I cam see from latest released version libvirt-0.10.2-54.el6_7.2 at [1]


[1] https://errata.devel.redhat.com/advisory/21710/builds
Comment 6 Triveni Rao 2015-12-11 02:12:19 EST
i was able to install RHEL6.7 based RHGS312 nodes successfully with above provided build and package  vdsm-4.16.30-1.2.el6rhs.

Output:
======================
[root@dhcp37-136 yum.repos.d]# rpm -qa | grep gluster
glusterfs-client-xlators-3.7.5-10.el6rhs.x86_64
glusterfs-server-3.7.5-10.el6rhs.x86_64
vdsm-gluster-4.16.30-1.2.el6rhs.noarch
gluster-nagios-common-0.2.3-1.el6rhs.noarch
glusterfs-3.7.5-10.el6rhs.x86_64
glusterfs-api-3.7.5-10.el6rhs.x86_64
glusterfs-cli-3.7.5-10.el6rhs.x86_64
glusterfs-geo-replication-3.7.5-10.el6rhs.x86_64
python-gluster-3.7.5-10.el6rhs.noarch
gluster-nagios-addons-0.2.5-1.el6rhs.x86_64
glusterfs-libs-3.7.5-10.el6rhs.x86_64
glusterfs-fuse-3.7.5-10.el6rhs.x86_64
glusterfs-rdma-3.7.5-10.el6rhs.x86_64
[root@dhcp37-136 yum.repos.d]# 

[root@dhcp37-136 yum.repos.d]# rpm -qa | grep vdsm
vdsm-xmlrpc-4.16.30-1.2.el6rhs.noarch
vdsm-yajsonrpc-4.16.30-1.2.el6rhs.noarch
vdsm-gluster-4.16.30-1.2.el6rhs.noarch
vdsm-python-4.16.30-1.2.el6rhs.noarch
vdsm-cli-4.16.30-1.2.el6rhs.noarch
vdsm-jsonrpc-4.16.30-1.2.el6rhs.noarch
vdsm-reg-4.16.30-1.2.el6rhs.noarch
vdsm-python-zombiereaper-4.16.30-1.2.el6rhs.noarch
vdsm-4.16.30-1.2.el6rhs.x86_64

[root@dhcp37-136 yum.repos.d]# cat /etc/redhat-storage-release 
Red Hat Gluster Storage Server 3.1 Update 2
[root@dhcp37-136 yum.repos.d]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.7 (Santiago)
[root@dhcp37-136 yum.repos.d]# 
[root@dhcp37-136 yum.repos.d]# 


The bug is verified.
Comment 8 errata-xmlrpc 2016-03-01 01:12:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0310.html

Note You need to log in before you can comment on or make changes to this bug.