Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Cause: There was a bug in nss_check_host function returning failure when matching SAN hostname was found in certificate.
Consequence: mailx with strict SSL verification enabled failed to connect to a server with SAN hostname in certificate.
Fix: nss_check_host function was fixed to return proper value.
Result: mail with strict SSL verification is now able to connect to a server with SAN hostname in certificate.
Description of problem:
mailx always fails when attempting to perform an SMTP send to a secure server if strict verification is set, regardless of nss-config-dir contents.
Version-Release number of selected component (if applicable):
How reproducible:
Always
Steps to Reproduce:
mailx -S smtp=smtps://smtp.example.com:465 \
-S ssl-verify=strict \
-S nss-config-dir=/etc/pki/nssdb \
-s 'Testing secure send' \
user
Actual results:
Resolving host smtp.example.com . . . done.
Connecting to 192.168.0.10:465 . . . connected.
Comparing DNS name: "smtp.example.com"
"/home/joe/dead.letter" 14/382
. . . message not sent.
Expected results:
mail should be sent.
Additional info:
Send fails regardless of contents of nss db in referenced directory.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2017:1869
Description of problem: mailx always fails when attempting to perform an SMTP send to a secure server if strict verification is set, regardless of nss-config-dir contents. Version-Release number of selected component (if applicable): How reproducible: Always Steps to Reproduce: mailx -S smtp=smtps://smtp.example.com:465 \ -S ssl-verify=strict \ -S nss-config-dir=/etc/pki/nssdb \ -s 'Testing secure send' \ user Actual results: Resolving host smtp.example.com . . . done. Connecting to 192.168.0.10:465 . . . connected. Comparing DNS name: "smtp.example.com" "/home/joe/dead.letter" 14/382 . . . message not sent. Expected results: mail should be sent. Additional info: Send fails regardless of contents of nss db in referenced directory.