Bug 1290066 - Node finishes introspection but is unable to be set to 'available' status
Node finishes introspection but is unable to be set to 'available' status
Status: CLOSED DUPLICATE of bug 1343744
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic-inspector (Show other bugs)
8.0 (Liberty)
x86_64 Linux
high Severity high
: ---
: 8.0 (Liberty)
Assigned To: Dmitry Tantsur
Raviv Bar-Tal
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 10:26 EST by Jamie Duncan
Modified: 2016-08-19 04:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-19 04:15:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Duncan 2015-12-09 10:26:35 EST
Description of problem:



Version-Release number of selected component (if applicable):

OSP 8.0 beta 1

How reproducible:

always as far as we can tell

Actual results:

stacktrace and node is unavailable for use 

Expected results:

system finishes introspection process cleanly

Additional info:

$ time openstack baremetal introspection bulk start
Setting available nodes to manageable...
Starting introspection of node: cee46f0d-fdfd-4358-8e66-a7a04e6dc4ca
Starting introspection of node: 51c85ebb-c133-4c26-a93c-cfaa0b3fddeb
Starting introspection of node: 17e38537-e02c-43d6-9720-73aa656a190d
Starting introspection of node: 2aae74cd-04eb-413e-9dbb-7f02d3fbf53d
Starting introspection of node: 72a2a95f-7cb1-4975-8e36-5a13375c779c
Waiting for introspection to finish...
Introspection for UUID 17e38537-e02c-43d6-9720-73aa656a190d finished successfully.
Introspection for UUID 2aae74cd-04eb-413e-9dbb-7f02d3fbf53d finished successfully.
Introspection for UUID 72a2a95f-7cb1-4975-8e36-5a13375c779c finished successfully.                                                                                                       
Introspection for UUID cee46f0d-fdfd-4358-8e66-a7a04e6dc4ca finished successfully.
Introspection for UUID 51c85ebb-c133-4c26-a93c-cfaa0b3fddeb finished successfully.

Setting manageable nodes to available...

Node cee46f0d-fdfd-4358-8e66-a7a04e6dc4ca has been set to available.

Request returned failure status.
Error contacting Ironic server: Node 51c85ebb-c133-4c26-a93c-cfaa0b3fddeb is locked by host undercloud.default.redhat.local, please retry after the current operation is completed.
Traceback (most recent call last):

  File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/server.py", line 142, in inner
      return func(*args, **kwargs)
   return func(*args, **kwargs)                                                                                                                                                [98/1185]
  File "/usr/lib/python2.7/site-packages/ironic/conductor/manager.py", line 1149, in do_provisioning_action
    % action) as task:
  File "/usr/lib/python2.7/site-packages/ironic/conductor/task_manager.py", line 152, in acquire
    driver_name=driver_name, purpose=purpose)
  File "/usr/lib/python2.7/site-packages/ironic/conductor/task_manager.py", line 221, in __init__
    self.release_resources()
  File "/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 195, in __exit__
    six.reraise(self.type_, self.value, self.tb)
  File "/usr/lib/python2.7/site-packages/ironic/conductor/task_manager.py", line 203, in __init__
    self._lock()
  File "/usr/lib/python2.7/site-packages/ironic/conductor/task_manager.py", line 242, in _lock
    reserve_node()
  File "/usr/lib/python2.7/site-packages/retrying.py", line 68, in wrapped_f
    return Retrying(*dargs, **dkw).call(f, *args, **kw)
  File "/usr/lib/python2.7/site-packages/retrying.py", line 229, in call
    raise attempt.get()
  File "/usr/lib/python2.7/site-packages/retrying.py", line 261, in get
    six.reraise(self.value[0], self.value[1], self.value[2])
  File "/usr/lib/python2.7/site-packages/retrying.py", line 217, in call
    attempt = Attempt(fn(*args, **kwargs), attempt_number, False)
  File "/usr/lib/python2.7/site-packages/ironic/conductor/task_manager.py", line 235, in reserve_node
    self.node_id)
  File "/usr/lib/python2.7/site-packages/ironic/objects/node.py", line 228, in reserve
    db_node = cls.dbapi.reserve_node(tag, node_id)
  File "/usr/lib/python2.7/site-packages/ironic/db/sqlalchemy/api.py", line 226, in reserve_node
    host=node['reservation'])
NodeLocked: Node 51c85ebb-c133-4c26-a93c-cfaa0b3fddeb is locked by host undercloud.default.redhat.local, please retry after the current operation is completed.
 (HTTP 409). Attempt 1 of 6
Request returned failure status.
Error contacting Ironic server: Node 51c85ebb-c133-4c26-a93c-cfaa0b3fddeb is locked by host undercloud.default.redhat.local, please retry after the current operation is completed.
Traceback (most recent call last):

  File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/server.py", line 142, in inner
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/ironic/db/sqlalchemy/api.py", line 226, in reserve_node
    host=node['reservation'])

NodeLocked: Node 51c85ebb-c133-4c26-a93c-cfaa0b3fddeb is locked by host undercloud.default.redhat.local, please retry after the current operation is completed.
 (HTTP 409). Attempt 2 of 6

...
Comment 4 Dmitry Tantsur 2016-08-19 04:15:16 EDT

*** This bug has been marked as a duplicate of bug 1343744 ***

Note You need to log in before you can comment on or make changes to this bug.