Bug 1290067 - After F22 to F23 upgrade, Workrave crashes on launch (segfault)
After F22 to F23 upgrade, Workrave crashes on launch (segfault)
Status: CLOSED DUPLICATE of bug 1267729
Product: Fedora
Classification: Fedora
Component: workrave (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 10:28 EST by Sam Tuke
Modified: 2015-12-16 10:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 04:12:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Workrave SRPM (6.49 MB, application/x-rpm)
2015-12-16 10:17 EST, Sam Tuke
no flags Details

  None (edit)
Description Sam Tuke 2015-12-09 10:28:27 EST
Description of problem:

Workrave worked correctly in F22; but after using DNF to upgrade to F23 it now crashes on launch.
Version-Release number of selected component (if applicable):
1.10 (9.fc23)

How reproducible:
Always

Steps to Reproduce:
1. Use workrave on F22 successfully
2. Use DNF to upgrade F22 to F23
3. Launch Workrave

Actual results:
Workrave crashes immediately ("Segmentation fault (core dumped)")

Expected results:
Workrave runs correctly.

Additional info:
Comment 1 Steve Ratcliffe 2015-12-13 07:51:25 EST
I downloaded the srpm and attempted to re-build it.

It did not compile.  The error indicated that the -std=gnu++11 flag
should be added to CXXFLAGS.

It started up correctly after rebuilding and re-installing with that change.
Comment 2 Lukas Zapletal 2015-12-14 04:12:24 EST
Hello, 

thanks for the report. We are tracking this as bug 1267729.

By the way, what SRPM did you download and can you attach the patch here? For me, it did not compile because of an extra slash in a Makefile, so my patch is slightly different. I would like to compare. Thanks!

There is a new version upstream which might fix it already.

*** This bug has been marked as a duplicate of bug 1267729 ***
Comment 3 Steve Ratcliffe 2015-12-15 06:28:01 EST
Hi

Thanks, I saw bug 1267729 after writing my comment.  I can try it if
it needs testing.

FYI I just used dnf download --source to obtain workrave-1.10-9.fc23.src.rpm

I didn't have a problem with any extra slash, the DISTRIBUTION_HOME
path does not end in a slash in that version. I just added the
flag to the CXXFLAGS in configure in Patch2:

--- ./configure.stdc11	2013-01-13 09:58:54.000000000 +0000
+++ ./configure	2015-12-13 12:40:25.631248037 +0000
@@ -6505,7 +6505,7 @@
 { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_prog_cxx_g" >&5
 $as_echo "$ac_cv_prog_cxx_g" >&6; }
 if test "$ac_test_CXXFLAGS" = set; then
-  CXXFLAGS=$ac_save_CXXFLAGS
+  CXXFLAGS="$ac_save_CXXFLAGS -std=gnu++11"
 elif test $ac_cv_prog_cxx_g = yes; then
   if test "$GXX" = yes; then
     CXXFLAGS="-g -O2"
Comment 4 Sam Tuke 2015-12-16 10:17 EST
Created attachment 1106475 [details]
Workrave SRPM
Comment 5 Sam Tuke 2015-12-16 10:18:16 EST
(In reply to Lukas Zapletal from comment #2)
> Hello, 
> 
> thanks for the report. We are tracking this as bug 1267729.
> 
> By the way, what SRPM did you download and can you attach the patch here?
> For me, it did not compile because of an extra slash in a Makefile, so my
> patch is slightly different. I would like to compare. Thanks!
> 
> There is a new version upstream which might fix it already.
> 
> *** This bug has been marked as a duplicate of bug 1267729 ***

SRPM attached -- thanks!
Comment 6 Sam Tuke 2015-12-16 10:18:57 EST
(In reply to Steve Ratcliffe from comment #3)
> FYI I just used dnf download --source to obtain workrave-1.10-9.fc23.src.rpm

Thanks for that, attached the SRPM.

Note You need to log in before you can comment on or make changes to this bug.