Bug 1290107 - [Trove] swift_url (trove-guestagent.conf) has the default value, breaking backups
[Trove] swift_url (trove-guestagent.conf) has the default value, breaking bac...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ga
: 8.0 (Liberty)
Assigned To: Gaël Chamoulaud
Luigi Toscano
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 11:43 EST by Luigi Toscano
Modified: 2016-04-07 17:17 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.3-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:17:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1506956 None None None Never
OpenStack gerrit 256444 None None None Never

  None (edit)
Description Luigi Toscano 2015-12-09 11:43:24 EST
Description of problem:
(from the upstream bug, still relevant)

The value for swift_url remains the default one, so http://localhost:8080/v1/AUTH_, and it's not replaced with the correct value. This breaks backups.

I suspect the reason is similar to the one for https://bugs.launchpad.net/puppet-trove/+bug/1506835: trove-guestagent.conf is configured through a template called from the trove::taskmanager class, somehow ignoring trove::guestagent (where swift_url is properly set), but my puppet knowledge is quite low.

Version-Release number of selected component (if applicable):
openstack-packstack-puppet-7.0.0-0.7.dev1661.gaf13b7e.el7ost.noarch
openstack-packstack-7.0.0-0.7.dev1661.gaf13b7e.el7ost.noarch
I think the version of imported puppet-trove code match the master on puppet-trove git repository upstream.
Comment 5 Luigi Toscano 2016-02-25 06:42:15 EST
swift_url is now properly filled with the correct value (base URL of swift entry point) in /etc/trove/trove.conf and /etc/trove/trove-guestagent.conf.

Verified with:
openstack-puppet-modules-7.0.6-2.el7ost.noarch

Using packstack:
openstack-packstack-7.0.0-0.12.dev1699.g8f54936.el7ost.noarch
openstack-packstack-puppet-7.0.0-0.12.dev1699.g8f54936.el7ost.noarch
Comment 6 errata-xmlrpc 2016-04-07 17:17:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.