This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1290130 - minimum number of Ceph PGs is not met when deploying with director
minimum number of Ceph PGs is not met when deploying with director
Status: CLOSED DUPLICATE of bug 1286841
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 12:26 EST by Dan Yocum
Modified: 2016-04-18 02:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-09 12:34:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2015-12-09 12:26:44 EST
Description of problem:

After deploying with director, 'ceph health' shows this error:

HEALTH_WARN too few pgs per osd (19 < min 30)


Version-Release number of selected component (if applicable):

7.1

How reproducible:

Every

Steps to Reproduce:
1. Leave the default value for ceph::profile::params::osd_pool_default_pg_num: 128 in ceph.yaml hiera file
2. deploy overcloud


Actual results:

#ceph health
HEALTH_WARN too few pgs per osd (19 < min 30)


Expected results:

no error or warning

Additional info:

All hiera data files should contain appropriate comments directing operators to set values accordingly (with URLs to supporting documentation.)

The Director Install and Config guide should contain the same documentation.
Comment 2 Mike Burns 2015-12-09 12:34:38 EST

*** This bug has been marked as a duplicate of bug 1286841 ***

Note You need to log in before you can comment on or make changes to this bug.