Bug 1290136 - python-rospkg fails to rebuild on aarch64/ppc64le
python-rospkg fails to rebuild on aarch64/ppc64le
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-rospkg (Show other bugs)
rawhide
aarch64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rich Mattes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7aarch64 ARM64/F-ExcludeArch-aarch64
  Show dependency treegraph
 
Reported: 2015-12-09 12:43 EST by Yaakov Selkowitz
Modified: 2015-12-30 13:04 EST (History)
2 users (show)

See Also:
Fixed In Version: python-rospkg-1.0.38-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-30 13:04:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaakov Selkowitz 2015-12-09 12:43:51 EST
Attempting to rebuild python-rospkg on an aarch64 machine fails due to the following test:

https://github.com/ros-infrastructure/rospkg/blob/master/test/test_rospkg_os_detect.py#L365

I'm not sure if that means only the listed architectures are supported, or if this is just a sanity test and other known architectures should be added to that list.
Comment 1 Rich Mattes 2015-12-09 19:22:22 EST
It's just a sanity test.  I'm kind of confused that the package appears to have built successfully as recently as november on s390 and arm koji, I guess there are/were non-secondary arch builders that build noarch packages?  

Anyway, I'll make a patch and submit a pull request to add the additional arches that Fedora supports:

aarch64
ppc64le
s390
s390x

If you can think of any other uname -m strings let me know.
Comment 2 Yaakov Selkowitz 2015-12-09 20:05:58 EST
(In reply to Rich Mattes from comment #1)
> It's just a sanity test.  I'm kind of confused that the package appears to
> have built successfully as recently as november on s390 and arm koji, I
> guess there are/were non-secondary arch builders that build noarch packages?

Currently, Fedora noarch packages are first built on primary koji (exactly which builder is luck-of-the-draw) then imported into secondary kojis without being rebuilt.  However, for EPEL 7, ppc64le is in the process of being added to the primary koji, with aarch64 to follow in 2016.  Therefore, in the very near future, epel7 noarch builds might end up built on one of the new arches, in which case a future build of this package will fail needlessly.  The same would apply to Fedora builds should any of these arches be moved to the primary koji.

> Anyway, I'll make a patch and submit a pull request to add the additional
> arches that Fedora supports:
> 
> aarch64
> ppc64le
> s390
> s390x
> 
> If you can think of any other uname -m strings let me know.

I think that covers it.  For the reasons stated above, please merge this into epel7 as well.
Comment 3 Scott K Logan 2015-12-09 20:24:21 EST
I already had to patch this test once in upstream to support armv7hl. I think that was about 2 years ago, though. They were largely supportive of the change.

--scott
Comment 4 Rich Mattes 2015-12-09 21:48:51 EST
Yes, I saw you in the git blame when I was trying to figure out when this test was added :)

I will apply the patch to epel 7 and rawhide, and let the rest of the branches be until the next upstream release.

Upstream pull request at:
https://github.com/ros-infrastructure/rospkg/pull/95
Comment 5 Fedora Update System 2015-12-09 22:11:16 EST
python-rospkg-1.0.38-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-1e501c119f
Comment 6 Fedora Update System 2015-12-10 06:21:33 EST
python-rospkg-1.0.38-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update python-rospkg'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-1e501c119f
Comment 7 Fedora Update System 2015-12-30 13:03:56 EST
python-rospkg-1.0.38-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.