This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1290159 - Initial/Delta Refreshes 27-65% of time in the ruby garbage collector depending on provider size
Initial/Delta Refreshes 27-65% of time in the ruby garbage collector dependin...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Performance (Show other bugs)
5.3.0
Unspecified Unspecified
medium Severity high
: GA
: 5.5.2
Assigned To: dmetzger
Alex Krzos
: ZStream
Depends On:
Blocks: 1220910
  Show dependency treegraph
 
Reported: 2015-12-09 14:06 EST by John Prause
Modified: 2016-02-10 10:23 EST (History)
8 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 10:23:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CLI output from stackprof on 4 initial refreshes per provider and 4 delta refreshes per provider (96.91 KB, text/plain)
2015-12-11 09:01 EST, Alex Krzos
no flags Details

  None (edit)
Description John Prause 2015-12-09 14:06:48 EST
I needed to create this NEW bugzilla issue as a clone of:
https://bugzilla.redhat.com/show_bug.cgi?id=1220910

I couldn't clone 1220910 since the comments section is now so long, it's preventing anyone from cloning that issue. Hence, this issue as the clone.

Rather than add details/comments from original, please see for details: https://bugzilla.redhat.com/show_bug.cgi?id=1220910
Comment 2 dmetzger 2015-12-10 10:37:18 EST
Given all the recent code changes regarding memory utilization, plus the updated Ruby & Rails versions, can we get date for either Master or 5.5?
Comment 3 Alex Krzos 2015-12-11 08:59:36 EST
Versions:
Miq master appliance (Built 2015-12-08)
manageiq-ovirt-master-201512082000-a918d3d3f6.ova
# ruby -v
ruby 2.2.3p173 (2015-08-18 revision 51636) [x86_64-linux]
# rails -v
Rails 4.2.5

Initial Refresh (GC %):
S - 10.51%-11.87%
M - 11.02%-11.85%
L - 13.49%-15.07%
XL- 19.94%-20.87%


Delta Refresh (GC %):
S - 6.06% -14.53%
M - 8.65% -13.06%
L - 9.16% -11.59%
XL- 12.27%-13.62%

Basic stackprof data will be attached.
Comment 4 Alex Krzos 2015-12-11 09:01 EST
Created attachment 1104698 [details]
CLI output from stackprof on 4 initial refreshes per provider and 4 delta refreshes per provider
Comment 5 dmetzger 2015-12-18 14:08:18 EST
Time spent in garbage collection has is now about 1/4 or less of the time previously spent in garbage collection. This ticket is being closed as we have met the goal of this ticket (reduction in garbage collection time), additionally efforts to reduce the time spent performing garbage collection will continue as part of regular performance work.
Comment 7 Ramesh A 2016-01-19 08:31:07 EST
Hi Dennis,

How to test this issue from QE prospective?

Thanks,
Ramesh
Comment 8 dmetzger 2016-01-19 09:42:09 EST
Hi Ramesh,

Stackprof has been the tool of choice to get the data. Inject stackprof in the environment, add a provider then run the report. Alex's Small/Medium/Large/XLarge environments have be the gold standard for reference.

Dennis
Comment 9 Alex Krzos 2016-02-05 16:10:21 EST
Reran on 5.5.2.4:

# ruby -v
ruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-linux]
# rails -v
Rails 4.2.5.1

Initial Refresh (GC %):
S - 10.39%-11.05%
M - 10.79%-12.46%
L - 14.20%-15.21%
XL- 20.67%-21.78%


Delta Refresh (GC %):
S - 6.11%-10.38%
M - 8.62%-13.75%
L - 9.93%-12.54%
XL- 11.52%-13.15%

This is a huge improvement compared to the percentage of gc time I have seen in the 5.3 cfme appliance (original BZ).
Comment 10 errata-xmlrpc 2016-02-10 10:23:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.