Bug 1290215 - CloudForms 3.2 edit catalog item fails
CloudForms 3.2 edit catalog item fails
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity high
: GA
: 5.5.2
Assigned To: Drew Bomhof
Dmitry Misharov
: ZStream
Depends On: 1236966
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 16:11 EST by John Prause
Modified: 2016-02-10 10:23 EST (History)
11 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, editing a catalog item could fail with an undefined method error if a resource pool or EMS folder was removed from the catalog item. This bug was fixed by changing the code to allow for removal of the resource pool or EMS folder from the catalog item. Editing a catalog item no longer fails in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1236966
Environment:
Last Closed: 2016-02-10 10:23:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2015-12-16 20:31:50 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=06566ce47103368d6fa77ce70cecc0e5dce2ece5

commit 06566ce47103368d6fa77ce70cecc0e5dce2ece5
Merge: 59ca020 ae4252c
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Wed Dec 16 20:27:12 2015 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Wed Dec 16 20:27:12 2015 -0500

    Merge branch '5.5.z_edit_catalog_item_fails' into '5.5.z'
    
    Editing a catalog item no longer fails in a bad way
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290215
    
    Editing a catalog item will no longer fail with an error
    If a resource pool or ems folder is removed from an
    existing catalog item.
    
    Upstream
    BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1236966
    PR: https://github.com/ManageIQ/manageiq/pull/5784
    
    Cherry-pick was clean
    
    See merge request !625

 app/models/miq_request_workflow.rb       |  4 +--
 spec/models/miq_request_workflow_spec.rb | 57 ++++++++++++++++++++++++++++----
 2 files changed, 53 insertions(+), 8 deletions(-)
Comment 5 Dmitry Misharov 2016-01-21 04:34:13 EST
Verified fixed in 5.5.2.1.20160114044944_395c086.
After removing resource pool, which is used in catalog item, editing this catalog item doesn't cause the aforementioned error.
Comment 6 errata-xmlrpc 2016-02-10 10:23:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.