Bug 1290244 - Using ksvalidator -v RHEL6 does not identify "--reserved-percent" as a valid option
Using ksvalidator -v RHEL6 does not identify "--reserved-percent" as a valid ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pykickstart (Show other bugs)
7.2
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
Clayton Spicer
:
Depends On:
Blocks: 1203710 1295926 1313485
  Show dependency treegraph
 
Reported: 2015-12-09 17:32 EST by jcastran
Modified: 2016-11-03 20:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: pykickstart-1.99.66.7-1
Doc Type: Bug Fix
Doc Text:
Kickstart files valid for Red Hat Enterprise Linux 6 are now correctly recognized by "ksvalidator" Previously, when using the "ksvalidator" utility to validate a Kickstart file made for Red Hat Enterprise Linux 6 that uses the "logvol" command with the `--reserved-percent` option, "ksvalidator" incorrectly stated that `--reserved-percent` is not a valid option. This bug has been fixed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 20:11:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jcastran 2015-12-09 17:32:36 EST
Description of problem:
If I validate a RHEL6 kickstart on a RHEL7 server using pykickstart's ksvalidator (pykickstart-1.99.43.17-1.el7), it errors saying that "reserved-percent" is not valid.  Using the older version supplied with RHEL6 (pykickstart-1.74.20-1.el6) does not error.
The documentation for RHEL6 indicated that the option is in fact supported (confirm with a test deploy):
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/s1-kickstart2-options.html
--reserved-percent= — Specify a percentage of total volume group space to leave unused. Only usable when creating a new volume group. 

Version-Release number of selected component (if applicable):
Rhel 7.0
Rhel 7.1
Rhel 7.2

How reproducible:
Every time

Steps to Reproduce:
1. include  "--reserved-percent=" on a Rhel 6 kickstart
2. run ksvalidator -v RHEL6 /location/of/kickstart


Actual results:
no such option: --reserved-percent

Expected results:
--reserved-percent is a valid option. 

Additional info:
This is a valid option for RHEL 7 kickstart as well. Thus, running ksvalidator against the kickstart without specifying the version will work (So long as no removed options are used)
Comment 1 Eric S. 2015-12-10 08:31:34 EST
Just a bit more info:

This does work properly in 1.74 (the version in RHEL6).  The validation function for volgroup differs between these versions:

From volgroup.py v.1.74:
 class RHEL6_VolGroup(F16_VolGroup):

And from v.1.99:
 class RHEL6_VolGroup(FC3_VolGroup):

FC16_VolGroup inherits from FC3_VolGroup and adds "--reserved-percent" as a valid option.  Using FC16_VolGroup in 1.99 allows it to work as expected (as well as adjusting the parse line later in the function).
Comment 2 Chris Lumens 2016-01-27 13:25:37 EST
Needs a cherry-pick of 207ca9a5f371415096a2a3f3d9d88798a7ecd9ef.
Comment 3 Eric S. 2016-02-17 08:27:42 EST
FYI: One of my coworkers submitted a patch for this issue which was merged in the upstream project:

https://github.com/rhinstaller/pykickstart/pull/53
Comment 4 Eric S. 2016-02-17 08:28:59 EST
Ah I see that is the commit that was referred to.  Awesome, sorry for the noise.
Comment 13 errata-xmlrpc 2016-11-03 20:11:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2184.html

Note You need to log in before you can comment on or make changes to this bug.