Bug 1290265 - [abrt] blueman: Device.py:26:err:blueman.bluez.errors.DBusAuthenticationFailedError: Authentication Failed
[abrt] blueman: Device.py:26:err:blueman.bluez.errors.DBusAuthenticationFaile...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pete Walter
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:7e24cbe85c4abbe9d304784ce82...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 18:54 EST by Peter F. Patel-Schneider
Modified: 2016-12-20 11:51 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 11:51:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (610 bytes, text/plain)
2015-12-09 18:54 EST, Peter F. Patel-Schneider
no flags Details
File: environ (2.41 KB, text/plain)
2015-12-09 18:54 EST, Peter F. Patel-Schneider
no flags Details

  None (edit)
Description Peter F. Patel-Schneider 2015-12-09 18:54:52 EST
Description of problem:
Trying to connect to an Apple Magic trackpad.

Version-Release number of selected component:
blueman-2.1-0.3.git7a2e20e.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        python3 /usr/bin/blueman-manager
executable:     /usr/bin/blueman-manager
kernel:         4.2.6-301.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1316

Truncated backtrace:
Device.py:26:err:blueman.bluez.errors.DBusAuthenticationFailedError: Authentication Failed

Traceback (most recent call last):
  File "/usr/lib64/python3.4/site-packages/dbus/connection.py", line 607, in msg_reply_handler
    *message.get_args_list()))
  File "/usr/lib/python3.4/site-packages/blueman/bluez/Device.py", line 26, in err
    raise exception
blueman.bluez.errors.DBusAuthenticationFailedError: Authentication Failed

Local variables in innermost frame:
e: DBusException(dbus.String('Authentication Failed'),)
exception: DBusAuthenticationFailedError('Authentication Failed',)
error_handler: None
Comment 1 Peter F. Patel-Schneider 2015-12-09 18:54:57 EST
Created attachment 1104198 [details]
File: backtrace
Comment 2 Peter F. Patel-Schneider 2015-12-09 18:54:58 EST
Created attachment 1104199 [details]
File: environ
Comment 3 Brian J. Murrell 2016-01-15 10:58:34 EST
Can this ticket get some attention please?  Bluetooth HFP headsets have been broken on Fedora for literally years.  It appears to be in some shape to be functional except for usability issues like this.

Can we please finally get these Bluetooth (HFP) issues on Fedora behind us?
Comment 4 Sam Tygier 2016-03-06 14:37:30 EST
Trying to connect to a NAD D3020
Comment 5 Antti Huhtala 2016-04-05 03:33:49 EDT
Pairing seems to work, PIN code inquiry fails.
Comment 6 leigh scott 2016-04-05 05:33:07 EDT
Please test blueman-2.0.4

https://koji.fedoraproject.org/koji/buildinfo?buildID=750694
Comment 7 Peter F. Patel-Schneider 2016-04-05 09:05:56 EDT
I am away from my Apple trackpad and will be for about another month so I will not be able to test this particular problem until then.

When this update gets into a repository I will try it out on the bluetooth devices I have with me, but they both do not trigger this particular problem.
Comment 8 Antti Huhtala 2016-04-09 12:33:58 EDT
Now that blueman-2.0.4 was updated with the appropriate blueman-libs, bluetooth started working in my case. It still reports "connection of the device failed" but connects anyway and, transferring (music) files to and from my phone is successful.
Comment 9 Sam Tygier 2016-04-09 12:45:20 EDT
Error is with blueman-2.1-0.3.git7a2e20e.fc23, blueman-2.0.4 looks like an older release. Is it a typo?

Also I am unable to reproduce today with blueman-2.1-0.3.git7a2e20e.fc23.x86_64
Comment 10 Antti Huhtala 2016-04-09 12:58:31 EDT
Not a typo but advice from leigh scott in comment #6. Mere blueman-2.0.4 build 750694 did not help but today during regular update I noticed blueman (or bluez) was updated with appropriate libs and bluetooth started working.
Comment 11 Babak Rezai 2016-06-10 17:22:39 EDT
liegh scott, thank you this solved my problem.
Comment 12 Babak Rezai 2016-06-10 17:22:47 EDT
liegh scott, thank you this solved my problem.
Comment 13 Jaroslav Škarvada 2016-06-21 07:54:48 EDT
Just trying to pair with Genius Navigator 900 Pro mouse and the problem happened.
Comment 14 Fedora Admin XMLRPC Client 2016-06-21 12:26:30 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 15 Fedora End Of Life 2016-11-24 09:07:30 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 16 Fedora End Of Life 2016-12-20 11:51:51 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.