Bug 129028 - japanese manpage is encoded by EUC-JP
japanese manpage is encoded by EUC-JP
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: w3m (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-03 06:01 EDT by Hisaya FUKUMOTO
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.5.1-3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 04:53:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hisaya FUKUMOTO 2004-08-03 06:01:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.6) Gecko/20040627

Description of problem:
Japanese manpage is encoded by EUC-JP.
It's necessary to convert it into UTF-8.

Version-Release number of selected component (if applicable):
w3m-0.5-3

How reproducible:
Always

Steps to Reproduce:
1.export LAN=ja_JP.UTF-8
2.man 1 w3m
3.
    

Additional info:
Comment 1 Akira TAGOH 2004-08-04 21:10:12 EDT
Fixed in 0.5.1-3. pending for FC2 updates.
Comment 2 Lawrence Lim 2004-09-13 22:16:49 EDT
FC2-updates for w3m still does not exist. 
Comment 3 Thomas E. Dickey 2004-10-03 16:28:01 EDT
Bruno Haible claims that glibc would do this translation.
Does Fedora use a reduced set of runtime translations?
Comment 4 Akira TAGOH 2004-10-04 02:47:28 EDT
er, since the manpage doesn't have any tags to determine which
encoding is used, glibc shouldn't be able to do anything. instead, we
have the hacked man and groff to detect the encoding - if the manpage
is using non-UTF-8 encoding, it also shows the warning message on the
top of manpage.
Comment 5 Thomas E. Dickey 2004-10-04 17:29:17 EDT
oops - sorry.  I was looking at a comment about
message files in a different window and responded
to the wrong one.
Comment 6 Akira TAGOH 2004-10-15 04:53:18 EDT
fixed in 0.5.1-3.1 for FC2-updates

Note You need to log in before you can comment on or make changes to this bug.