Bug 1290300 - Global shared filters missing in services->workloads->Templates and Images
Global shared filters missing in services->workloads->Templates and Images
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Martin Hradil
Matouš Mojžíš
ui:filter
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 01:32 EST by Aziza Karol
Modified: 2016-06-29 11:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:19:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
akarol: automate_bug+


Attachments (Terms of Use)
filters missing (119.19 KB, image/png)
2015-12-10 01:32 EST, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-12-10 01:32:59 EST
Created attachment 1104233 [details]
filters missing

Description of problem:


Version-Release number of selected component (if applicable):
5.5.0.13.20151201120956_653c0d4 

How reproducible:
100%

Steps to Reproduce:
1.Navigate to services->workloads->Templates and Images
2.click on Global filters in All templates and images
3.

Actual results:
No Global filters displayed.see attached screenshot

Expected results:
Global filters  should be displayed.

Additional info:
Comment 2 Harpreet Kataria 2015-12-17 10:46:47 EST
Martin,

looking at db/fixtures/miq_searches.yml, looks like the default searches for Infra side VM explorer were changed to use db: ManageIQ::Providers::InfraManager::Vm and cloud Instance explorer searches were updated to use: db: ManageIQ::Providers::CloudManager::Vm and the ones for Workloads explorer weren't updated they are still db: Vm probably those need to be updated to the relevant class.

Let me know if you have questions.

Thanks,
~Harpreet
Comment 4 CFME Bot 2016-01-19 13:46:02 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/8e1eeb0b78f88afd6c2ad6771a972aa52311d2d1

commit 8e1eeb0b78f88afd6c2ad6771a972aa52311d2d1
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Mon Jan 18 18:16:45 2016 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Tue Jan 19 15:44:26 2016 +0000

    Services/Workloads - fix Templates & Images tree
    
    as it is, the tree in Templates & Images is empty. Looks like a typo when splitting the treebuilder instances, "Template" => "..InfraManager::Template".
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290300

 app/presenters/tree_builder_templates_images_filter.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 6 Matouš Mojžíš 2016-04-19 19:47:45 EDT
Verified in 5.6.0.1-beta2, I added rhevm provider and then navigated services->workloads->Templates and Images and clicked on Global Filters in All Templates and Images and Filtered Templates & Images have shown up.
Comment 8 errata-xmlrpc 2016-06-29 11:19:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.