Bug 1290304 - [RFE]Reducing number of network round trips
Summary: [RFE]Reducing number of network round trips
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1274908 1360978 1372686 1372693
TreeView+ depends on / blocked
 
Reported: 2015-12-10 06:49 UTC by Pranith Kumar K
Modified: 2017-03-06 17:20 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1360978 1372686 1372693 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:20:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2015-12-10 06:49:40 UTC
Description of problem:
In the unoptimized version of transaction we have: 1) Lock,
2) Pre-op 3) op 4) Post-op 5) unlock
With compound fops we will have:
1) Lock, 2) Pre-op + op 3) post-op + unlock
This reduces round trips from 5 to 3 in the un-optimized version 
of afr-transaction.

This helps in small file write workload.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-08-09 07:17:44 UTC
REVIEW: http://review.gluster.org/15014 (afr: Consume compound fops in afr transaction) posted (#2) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 2 Worker Ant 2016-08-25 11:03:06 UTC
REVIEW: http://review.gluster.org/15014 (afr: Consume compound fops in afr transaction) posted (#3) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 3 Worker Ant 2016-08-31 13:27:15 UTC
REVIEW: http://review.gluster.org/15014 (afr: Consume compound fops in afr transaction) posted (#4) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 4 Worker Ant 2016-08-31 23:48:01 UTC
REVIEW: http://review.gluster.org/15014 (afr: Consume compound fops in afr transaction) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 5 Worker Ant 2016-09-01 17:22:44 UTC
COMMIT: http://review.gluster.org/15014 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit befae0b48729894282b5b8b174907e24779c3442
Author: Anuradha Talur <atalur@redhat.com>
Date:   Thu Aug 25 11:46:25 2016 +0530

    afr: Consume compound fops in afr transaction
    
    Change-Id: Ib06ece3cce1b10d28d6d2953da28444f5c2457ad
    BUG: 1290304
    Signed-off-by: Anuradha Talur <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/15014
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 7 Shyamsundar 2017-03-06 17:20:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.