Bug 1290307 - Fail to install containerized env on RHEL72
Fail to install containerized env on RHEL72
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Scott Dodson
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 02:15 EST by Ma xiaoqiang
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:43:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2015-12-10 02:15:33 EST
Description of problem:
Fail to install containerized env on RHEL72

Version-Release number of selected component (if applicable):
https://github.com/sdodson/openshift-ansible  containers


How reproducible:
Always


Steps to Reproduce:

1. Install containerized on RHEL72
#vim hosts
<--snip-->
containerized=true
<--snip-->


Actual results:
TASK: [openshift_cli | Install clients] *************************************** 
failed: [10.66.79.156] => {"changed": false, "failed": true, "rc": 0, "results": []}
msg: No Package matching 'atomic-openshift-clients' found available, installed or updated

FATAL: all hosts have already failed -- aborting

QE get the fact from the log.
 "ip": "192.168.0.232", "is_atomic": false, "is_containerized": false, "public_hostname": 

Expected results:
Install env successfully.

Additional info:
Comment 1 Scott Dodson 2015-12-16 14:18:06 EST
This should be fixed in the latest code on the containers branch.
Comment 2 Ma xiaoqiang 2015-12-17 20:43:45 EST
Install successfully on rhel72
Comment 4 errata-xmlrpc 2016-01-27 14:43:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.