Bug 1290311 - Thinkpad E550 webcam not working (uvcvideo, 5986:055a)
Thinkpad E550 webcam not working (uvcvideo, 5986:055a)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 02:37 EST by Colin Macdonald
Modified: 2017-04-11 17:28 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-11 17:28:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Macdonald 2015-12-10 02:37:12 EST
Relevant log: "uvcvideo: No valid video chain found."

This is the Ubuntu bug:

https://bugs.launchpad.net/ubuntu/+source/linux-lts-utopic/+bug/1433906

I'm seeing this on an up-to-date F23 system running kernel 4.2.6-301.  I cannot easily test rawhide on this hardware at the moment but based on the Ubuntu bug, it looks like it would not help.
Comment 1 Colin Macdonald 2016-01-04 13:02:44 EST
Latest on this:

https://sourceforge.net/p/linux-uvc/mailman/message/34722467/
Comment 2 Suresh Chandra 2016-02-03 23:48:25 EST
I am using Lenovo ThinkPad e450 with Fedora 23 with my web cam is not working.
Comment 3 igasi 2016-02-29 11:22:55 EST
Hi, I am using a Lenovo Thinkpad e455 with Fedora 23 and I have the same error.

$ lsusb -d 5986:055a 
Bus 002 Device 002: ID 5986:055a Acer, Inc


$ lsmod | egrep -i "media|videodev"
videodev              167936  4 uvcvideo,v4l2_common,videobuf2_core,videobuf2_v4l2
media                  24576  2 uvcvideo,videodev


$ dmesg | grep uvcvideo
[   10.612919] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:055a)
[   10.626211] uvcvideo: No valid video chain found.
[   10.626342] usbcore: registered new interface driver uvcvideo
[ 7147.591264] usbcore: deregistering interface driver uvcvideo
[ 7167.784567] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:055a)
[ 7167.784574] uvcvideo: Forcing device quirks to 0x1000 by module parameter for testing purpose.
[ 7167.784577] uvcvideo: Please report required quirks to the linux-uvc-devel mailing list.
[ 7167.785804] uvcvideo: No valid video chain found.
[ 7167.786046] usbcore: registered new interface driver uvcvideo
Comment 4 igasi 2016-02-29 11:23:13 EST
Hi, I am using a Lenovo Thinkpad e455 with Fedora 23 and I have the same error.

$ lsusb -d 5986:055a 
Bus 002 Device 002: ID 5986:055a Acer, Inc


$ lsmod | egrep -i "media|videodev"
videodev              167936  4 uvcvideo,v4l2_common,videobuf2_core,videobuf2_v4l2
media                  24576  2 uvcvideo,videodev


$ dmesg | grep uvcvideo
[   10.612919] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:055a)
[   10.626211] uvcvideo: No valid video chain found.
[   10.626342] usbcore: registered new interface driver uvcvideo
[ 7147.591264] usbcore: deregistering interface driver uvcvideo
[ 7167.784567] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:055a)
[ 7167.784574] uvcvideo: Forcing device quirks to 0x1000 by module parameter for testing purpose.
[ 7167.784577] uvcvideo: Please report required quirks to the linux-uvc-devel mailing list.
[ 7167.785804] uvcvideo: No valid video chain found.
[ 7167.786046] usbcore: registered new interface driver uvcvideo
Comment 5 mazoo 2016-02-29 14:06:26 EST
I am using a Lenovo Thinkpad e550 and I do have the same error with Fedora 23.
Comment 6 Suresh Chandra 2016-03-01 01:47:39 EST
Hello Guys, 

I am using Lenovo ThinkPad e450, and I was having the same problem. my web cam was not working because my laptop has Acer 5986:055a web cam and Fedora 23 does not have any module for it. 

But after patching my kernel, now my web cam is working fine with cheese and Skype as well. Please do the following: 

Step 1: Change the Directory to "/usr/src/"

        [root@Thinkpad-E450 ~]# cd /usr/src/

Step 2: Now Download latest kernel from "kernel.org" using following command and than extract it.

        [root@Thinkpad-E450 src]# wget https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.4.1.tar.xz

        [root@Thinkpad-E450 src]# tar -xvf linux-4.4.1.tar.xztar.xz

        [root@Thinkpad-E450 src]# cd linux-4.4.1/

Step 3: Now Download the patch for web cam

        [root@Thinkpad-E450 linux-4.4.1]# wget -O webcam.patch https://launchpadlibrarian.net/229627414/0001-uvcvideo-Acer-Integrated-Camera-5986-055a-add-UVC_QU.patch


Step 4: Now patch it into kernel configuration using the following command

        [root@Thinkpad-E450 linux-4.4.1]# cat webcam.patch | patch -p1 --dry-run

        [root@Thinkpad-E450 linux-4.4.1]# cat webcam.patch | patch -p1

Step 5: Now install some dependency to compile and install kernel from source code

        [root@Thinkpad-E450 linux-4.4.1]# dnf install fedpkg fedora-packager rpmdevtools ncurses-devel pesign* gcc* qt* make* -y

        [root@Thinkpad-E450 linux-4.4.1]# dnf install qt3-devel qt-devel libXi-devel gcc-c++ openssl* -y

        [root@Thinkpad-E450 linux-4.4.1]# /usr/libexec/pesign/pesign-authorize-users

Step 6: Now use the following commands to compile the Linux Kernel

        [root@Thinkpad-E450 linux-4.4.1]# make clean

        [root@Thinkpad-E450 linux-4.4.1]# make mrproper

        [root@Thinkpad-E450 linux-4.4.1]# make mrproper

        [root@Thinkpad-E450 linux-4.4.1]# make menuconfig

        [root@Thinkpad-E450 linux-4.4.1]# make

        [root@Thinkpad-E450 linux-4.4.1]# make modules

        [root@Thinkpad-E450 linux-4.4.1]# make modules_install

        [root@Thinkpad-E450 linux-4.4.1]# make install

        [root@Thinkpad-E450 linux-4.4.1]# reboot
Comment 7 Laura Abbott 2016-09-23 15:31:58 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 8 Jesus Bajo 2016-09-28 11:23:53 EDT
Confirmed same issue en Fedora 24:

lsusb -d 5986:055a
Bus 002 Device 004: ID 5986:055a Acer, Inc 

lsmod |egrep -i "media|videodev"
videodev              172032  3 uvcvideo,videobuf2_core,videobuf2_v4l2
media                  36864  2 uvcvideo,videodev


dmesg | grep uvcvideo
[    9.077950] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:055a)
[    9.077979] uvcvideo: No valid video chain found.
[    9.078006] usbcore: registered new interface driver uvcvideo

cat /etc/redhat-release 
Fedora release 24 (Twenty Four)
Comment 9 Colin Macdonald 2016-09-28 12:46:49 EDT
Confirmed for F24 by Comment #8 (thanks!)

I don't have easy access to this hardware, but I suspect its still present in Rawhide too.  There is a patch here:

https://bugs.launchpad.net/ubuntu/+source/linux-lts-utopic/+bug/1433906

Sorry, I haven't tried it.
Comment 10 Justin M. Forbes 2017-04-11 10:46:56 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-100.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.
Comment 11 mazoo 2017-04-11 17:03:10 EDT
Works for Fedora 25. Thanks.

uname -r
4.10.8-200.fc25.x86_64

lsusb -d 5986:055a 
Bus 002 Device 005: ID 5986:055a Acer, Inc

lsmod | egrep -i "media|videodev"
videodev              172032  3 uvcvideo,videobuf2_core,videobuf2_v4l2
media                  40960  2 uvcvideo,videodev

dmesg | grep uvcvideo
[    5.232807] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:055a)
[    5.240633] uvcvideo 2-8:1.0: Entity type for entity Extension 4 was not initialized!
[    5.240636] uvcvideo 2-8:1.0: Entity type for entity Processing 2 was not initialized!
[    5.240638] uvcvideo 2-8:1.0: Entity type for entity Camera 1 was not initialized!
[    5.242266] usbcore: registered new interface driver uvcvideo

Note You need to log in before you can comment on or make changes to this bug.