Bug 1290320 - Fail to install openshift client package when ansible_pkg_mgr is 'dnf' on rhel72
Fail to install openshift client package when ansible_pkg_mgr is 'dnf' on rhel72
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Scott Dodson
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 03:47 EST by Ma xiaoqiang
Modified: 2016-07-03 20:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:43:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2015-12-10 03:47:32 EST
Description of problem:
Fail to install openshift client package when ansible_pkg_mgr is 'dnf' on rhel72

Version-Release number of selected component (if applicable):
https://github.com/sdodson/openshift-ansible  containers

How reproducible:
Always


Steps to Reproduce:

1.yum install the epel package
yum install http://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-5.noarch.rpm -y

2. yum install the dnf package 
yum install dnf
dnf remove yum

3. Install openshift via RPM on RHEL72



Actual results:
TASK: [openshift_cli | Install clients] *************************************** 
failed: [10.66.79.156] => {"failed": true, "parsed": false}
Traceback (most recent call last):
  File "/root/.ansible/tmp/ansible-tmp-1449734783.17-174270917687806/yum", line 27, in <module>
    import yum
ImportError: No module named yum
OpenSSH_6.6.1, OpenSSL 1.0.1e-fips 11 Feb 2013
debug1: Reading configuration data /home/jenkins2/.ssh/config
debug1: /home/jenkins2/.ssh/config line 5: Applying options for *
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 56: Applying options for *
debug1: auto-mux: Trying existing master
debug1: mux_client_request_session: master session id: 2



Expected results:
Install openshift client package successfully

Additional info:
Comment 1 Scott Dodson 2015-12-14 16:28:17 EST
I don't think this is related to containerized installation however I did rebase my branch to contain the latest work that abstracts away whether you're using yum or dnf.

Can you please give this another shot with the latest from the containers branch?
Comment 7 errata-xmlrpc 2016-01-27 14:43:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.