Bug 1290321 - Initial Setup doesn't full of the screen when the first boot.
Initial Setup doesn't full of the screen when the first boot.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initial-setup (Show other bugs)
7.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Martin Kolman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 03:48 EST by fine.fan
Modified: 2016-11-03 23:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: initial-setup-0.3.9.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:52:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unmax the window with double click and it said"__main__.py" (5.10 MB, image/jpeg)
2015-12-10 03:48 EST, fine.fan
no flags Details

  None (edit)
Description fine.fan 2015-12-10 03:48:29 EST
Created attachment 1104255 [details]
Unmax the window with double click and it said"__main__.py"

Description of problem:
When I finished the OS install and reboot, it got Initial Setup screen to let me accept the Licenses etc. But the screen doesn't full of the screen, so that I could see the windows title with "__main__.py" and could double click it to un max the window ,and drag it to move around.

Version-Release number of selected component (if applicable):

rhel-server-7.2-x86_64-dvd.iso

[root@localhost ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)

How reproducible:
100%

Steps to Reproduce:
1.Install the OS normally
2.Reboot the OS as it said
3.Get the Initial Setup screen appear.

Actual results:
It doesn't full of the screen ,and a window title with "__main__.py",which I could double click it to un max the window ,and drag it to move around.

Expected results:
It sould be full of the screen , and cant see a window title with "__main__.py"

Additional info:
Please see the attachment of the screen shots
Comment 1 Martin Kolman 2016-04-19 08:30:07 EDT
A fix that makes Initial Setup use the full screen real estate has been posted for review. The patch also hides the window header bar when Initial Setup is running with the Metacity window manager.
Comment 2 Chris Lumens 2016-05-10 14:09:29 EDT
Looks like this has been committed and built, so moving into MODIFIED.
Comment 3 Martin Kolman 2016-05-11 06:39:56 EDT
(In reply to Chris Lumens from comment #2)
> Looks like this has been committed and built, so moving into MODIFIED.

Well, while the Initial Setup side fix has been indeed pushed and released in 0.3.9.31-1, it still needs an additional Anaconda fix (https://github.com/rhinstaller/anaconda/commit/9f92cd870ae13ebb0fbcd5ea903c2e68f2393618) to work. So I've been waiting for the Anaconda fix to hit a release before setting the "Fixed In Version" field.
Comment 4 Martin Kolman 2016-05-13 10:34:15 EDT
So the fix added to Anaconda 21.48.22.71 fixes the header for good.

In short, you have anaconda >= 21.48.22.71-1 and initial-setup >= 0.3.9.31-1 then Initial Setup should be correctly using the full screen real estate.
Comment 6 Jan Stodola 2016-08-11 03:28:58 EDT
I'm no longer able to reproduce it with anaconda-21.48.22.81-1.el7 and initial-setup-0.3.9.32-1.el7, initial-setup is running in full screen.

Moving to VERIFIED.
Comment 8 errata-xmlrpc 2016-11-03 23:52:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2331.html

Note You need to log in before you can comment on or make changes to this bug.